summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/dask
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2021.12.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 0f7e0a63566d..26a624ad73eb 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,4 +1,6 @@
AUX dask-2021.10.0-warning.patch 1606 BLAKE2B 69d75601493a8702ad61e1e9411c1219a83a2251349e4112346215fa7d8f78e10ed1f4bd1f6f5ed1db14627e1b7ba24c8ebf180b9210589c27bdecdf3d94d207 SHA512 f0479c156cfc40c6501bbc4c1832abb2d36a322edce2b5827c05e7d6cea075e12c57c5f0460eeebe250ca049ad6df74eba7509a4517d654775c915391a6b6af4
DIST dask-2021.11.0.tar.gz 3971871 BLAKE2B be2c28782e3e870b62e70041bd7572783ff9eef61c27d2fa092f00b74ae23877163e3c00f59f67c5c39b6fefd723cb2c25cdc58b5f5c76c08ef1d686f256cb25 SHA512 cebdef68b2c40348c84627505f4e1f17f998aed603d590be5acc7b78233362330352be395396be00f72215b738e9393ef08eeae8ed0fb933466c1c2d6158e5ea
+DIST dask-2021.12.0.gh.tar.gz 3987797 BLAKE2B f6c1954ff41048861fcedbc56bd658989dece828613344e876e097d03f93338c194d66e62dd9fa1605b5dfd0362374a1dd2e00a383eec4476db16ac04de29266 SHA512 e9ce4613bf1ccfda7ce85bd90ff8f24d59335f02a941c12335214a2636f46ae1e1e8c2b1777ca9b9dd83f190071a2893b02bee129a68e9b7468c30f2a45df68e
EBUILD dask-2021.11.0.ebuild 1316 BLAKE2B 1da54c68cb9326c52fc931e636e973241b51e38c3f4772af018ceb04557010185c5a02de6b2f879b5cf41a34048182b8b034dba2fcb12350a03d9fb122d3949c SHA512 7a37317e26196ebe7f9bc223f814fd3dfccfb3630a5189f8ec38221bb3aee663323ae95c67cdcdff2789c3ec80f07847b9e7388634762bac486415e3e341f298
+EBUILD dask-2021.12.0.ebuild 1350 BLAKE2B a795c9aa32809957e0c5af07e71a14273d933fd5c897cd6c04a921536b3ea9594544ab1a8e6ef78f6a3515cd302b01a4e0209184f7bf3b7265960fdda16dc449 SHA512 5285dd3366fb72cc7aa0db596e6f678c65a459920e8c0b7646a0aa7253f202530816bc758aa0030283cd4527423a3e4af845fad192ba387eace426f22400cf6f
MISC metadata.xml 722 BLAKE2B f5ef083408180a71a3f997ab61bba6770b08018e3d0737a17a99827edd486c2d10fc8bf17c70c8d5a431bc40bdd685d2a6ce6e8e1784a2c1d89152b167f51648 SHA512 1e1a79bf0d919a2a7a0840e77f239b3aa3bcd57666a06f18113c39c9b075d03e380b37c2e9c96dfe8ba864a94e98fe52fc0b6b16e69009364374020729b261ef
diff --git a/dev-python/dask/dask-2021.12.0.ebuild b/dev-python/dask/dask-2021.12.0.ebuild
new file mode 100644
index 000000000000..9288cd53f482
--- /dev/null
+++ b/dev-python/dask/dask-2021.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/dask-2021.10.0-warning.patch
+)
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}