summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
commit529abfa74a08ae5099db9780bcdf8250aa52ecb6 (patch)
tree2e2d1a9fd6e89b4872499afea3dc57490271e69c /dev-python/dask
parente6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (diff)
gentoo auto-resync : 03:12:2022 - 14:59:58
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2022.12.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 0aeabd73413f..376243d23f48 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,5 +1,7 @@
DIST dask-2022.10.1.gh.tar.gz 8781108 BLAKE2B 2030cf0670d054a222123ef836573ae7f5e574a879089a57b9a7730ae5cc33e43da2af3b470ce24174169f9045415cf71543aa05fd368b4471111a01982c5b7c SHA512 58b5515be46086a02a895f97db7120423a51651dcefef6f14d631a719e4faa0315b7a32640e4cd823064ae754319b84cc7c74bb4d4e9d904177816115abc48e5
DIST dask-2022.11.1.gh.tar.gz 8223813 BLAKE2B 1c7f4ed26022673ebb3a337520eee4cfb6c48449c06bfc1906431de6f03b4a4df313630326f96cf5ef8aefdc1306ded21158946997d9cf79153f7d83659575bd SHA512 c954de12d512e5be7d4891e9e702ae21c69e42be703e3859bb2d6893dd600fc7255ce25677bfdf9e119f84450510877ce018ac8ef425291fdf90c04af169e2e7
+DIST dask-2022.12.0.gh.tar.gz 8226972 BLAKE2B 56def762c1899df9b355f54484b77cfde125e85287db488388130c92b388f014b7ddf8ccd4614918a5c6a15513c7fab207b4c2231105880a893af32e768ed675 SHA512 bc29f3735fb977a5b523d7ffbf55a99fd7a386388f1ebec3c44196d3b6870393163e023a2c64f1f8e7b8aae5342b9b0041a6628df72d14a0127513acf7f6c529
EBUILD dask-2022.10.1.ebuild 1779 BLAKE2B d7794dc3a690c8742b885b288c7600e2696246f9614f7c7f17f033f43ca864c5b22377d4c1d9a628661206b0765fdd0dbeed53d4d6cae31970dc30f3ec34dbc7 SHA512 6b49452b4764b0585bca056eacce39e41390c1de9844187466ed2e97ff23bef9ad19fc8eb8222d5abf545c125a7d39cff4916ff890b09d0dd7e177ccba01e4ed
EBUILD dask-2022.11.1.ebuild 1780 BLAKE2B 24148b6128c95f1b700b3a5f1d53cf1e05147bc234a7092d8d64991c99af531e18664e413d4c35124f6062a25f32da5112846297650c54d719f48a5aa7cd3761 SHA512 559f6e575414a68c1e2db39a355120abd40d60d17ac9bda60919d508e0414776c5a0abeea2e70adf6f19a6039edf101dd20cbccd9079b18cc2b7dcef9f6ad767
+EBUILD dask-2022.12.0.ebuild 1780 BLAKE2B 24148b6128c95f1b700b3a5f1d53cf1e05147bc234a7092d8d64991c99af531e18664e413d4c35124f6062a25f32da5112846297650c54d719f48a5aa7cd3761 SHA512 559f6e575414a68c1e2db39a355120abd40d60d17ac9bda60919d508e0414776c5a0abeea2e70adf6f19a6039edf101dd20cbccd9079b18cc2b7dcef9f6ad767
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2022.12.0.ebuild b/dev-python/dask/dask-2022.12.0.ebuild
new file mode 100644
index 000000000000..8f2f893b8e30
--- /dev/null
+++ b/dev-python/dask/dask-2022.12.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # another test relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+)
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}