summaryrefslogtreecommitdiff
path: root/dev-python/dask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /dev-python/dask
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/Manifest2
-rw-r--r--dev-python/dask/dask-2023.12.0.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 1712cbb50ef1..1f3d7b2c5727 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,3 +1,5 @@
DIST dask-2023.11.0.gh.tar.gz 8559592 BLAKE2B 3d9e2d049c4ef3a880caef56298dfe76033a79d60424554f9122e68354bd2be2c6c0aae3b833c84d5704c45167b050c65227a0b799a5131600a1417a09bd4d1f SHA512 1ebac9c9fb158682dc5063710fd11ccbe0f584cea26afad4b3fe01001f3f7d6888ddbb7653cfdaf2da4ca7acb2b88bc7b1d8b4055790e7036b419ae995346e8f
+DIST dask-2023.12.0.gh.tar.gz 8576162 BLAKE2B 2e7764a0f2181daf96b175f5d4ad473f126df88614f00d434f74a9f291c6f654ba4a0961ae95737164b5cfda88755fe5734bdaed4821a4d88df4780544bad14f SHA512 879d8a83f5659387bdfd425a68128b72745e693e9904164cfa2ff249682539d9051f5c19bcdf230cf3415b0f2253683dd6b286083be05124b2b5a900c9307104
EBUILD dask-2023.11.0.ebuild 2919 BLAKE2B cd51b4e720364d272bb0d2aa517927a77f36b5497bf29eb89f5dd6328515e600016d2ae3360cfe501d30e17b5764fb0bcc5bd52cb7f1c5e134957ebf251f1cfa SHA512 4574641ebc2eb7bbc0a1bc162e7597b0902e9f20ad485a33316d5d0f48f4242a8c55acbb96fcdffac2c55f131663f386b863d3b04ee30d2191dcda47305970e5
+EBUILD dask-2023.12.0.ebuild 2921 BLAKE2B 97b64f7860fa1cac94fed4decd263f843de3b0a520f26fda0d123c27e7105d042b6017802a298379838568f235f3e432e7ce2fd98b4ba514bd1d7f3020ae6a1b SHA512 8fd59868f8858334bb4efb7e67282575cb10bcd7fe5d67f7e8231ddea51e70132655461fc97a1245e5f57c3bc8956122c3304a12f011936c92a00bf3c902d88c
MISC metadata.xml 724 BLAKE2B 9af7553cec2b66228a21f146372d86b8d620048d68f94c1fd09006c8ee7ddaa4e212c2a359b937a5ee37ac23df01e10af0796e8b4cf952237cb4c73a2dff7ca0 SHA512 89b83402c13b06f7adf10cd1cc08b96b90dbc2ca3b5c0c6c422b6e2394e03fd51346306479557c11fcfdbd4a81a574890f2367228ea38531b5f05c02a30b8dcb
diff --git a/dev-python/dask/dask-2023.12.0.ebuild b/dev-python/dask/dask-2023.12.0.ebuild
new file mode 100644
index 000000000000..e2f5047c0cef
--- /dev/null
+++ b/dev-python/dask/dask-2023.12.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="
+ https://www.dask.org/
+ https://github.com/dask/dask/
+ https://pypi.org/project/dask/
+"
+SRC_URI="
+ https://github.com/dask/dask/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/click-8.1[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.9.0[${PYTHON_USEDEP}]
+ >=dev-python/importlib-metadata-4.13.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-1.2.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/versioneer-0.28[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fails with sqlalchemy-2.0, even though we don't use it x_x
+ sed -i -e '/RemovedIn20Warning/d' pyproject.toml || die
+ sed -i -e 's:--cov-config=pyproject.toml::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # more tests relying on -Werror
+ "dask/array/tests/test_overlap.py::test_map_overlap_no_depth[None]"
+ dask/array/tests/test_random.py::test_RandomState_only_funcs
+ # TODO
+ dask/array/tests/test_reductions.py::test_mean_func_does_not_warn
+ dask/tests/test_config.py::test__get_paths
+ dask/array/tests/test_linalg.py::test_solve_assume_a
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>0-float-5-1-True]"
+ "dask/dataframe/tests/test_dataframe.py::test_repartition_npartitions[<lambda>1-float-5-1-True]"
+ dask/array/tests/test_image.py::test_preprocess
+ dask/tests/test_system.py::test_cpu_count_cgroups_v2
+ # require sqlalchemy<2.0
+ dask/dataframe/io/tests/test_sql.py
+ # crashes
+ dask/tests/test_base.py::test_tokenize_object_with_recursion_error
+ )
+
+ if ! has_version -b "dev-python/pyarrow[parquet,${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # fails if pyarrow is installed without USE=parquet
+ # (optional dep, skipped if it's not installed at all)
+ dask/dataframe/io/tests/test_parquet.py::test_pyarrow_filter_divisions
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_rerunfailures -m "not network" \
+ -p xdist -n "$(makeopts_jobs)"
+}