summaryrefslogtreecommitdiff
path: root/dev-python/dask/dask-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/dask/dask-1.2.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/dask/dask-1.2.0.ebuild')
-rw-r--r--dev-python/dask/dask-1.2.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/dask/dask-1.2.0.ebuild b/dev-python/dask/dask-1.2.0.ebuild
new file mode 100644
index 000000000000..fdc031a5b83a
--- /dev/null
+++ b/dev-python/dask/dask-1.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="distributed test"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.23.4[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.8[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.7.3[${PYTHON_USEDEP}]
+ distributed? (
+ >=dev-python/distributed-1.16[${PYTHON_USEDEP}]
+ >=dev-python/s3fs-0.0.8[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.18.2-skip-broken-test.patch"
+)
+
+python_test() {
+ pytest -v dask || die
+}