summaryrefslogtreecommitdiff
path: root/dev-python/dap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/dap
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/dap')
-rw-r--r--dev-python/dap/Manifest5
-rw-r--r--dev-python/dap/dap-2.2.6.7-r1.ebuild34
-rw-r--r--dev-python/dap/metadata.xml22
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/dap/Manifest b/dev-python/dap/Manifest
new file mode 100644
index 000000000000..1e07c7f2194e
--- /dev/null
+++ b/dev-python/dap/Manifest
@@ -0,0 +1,5 @@
+DIST dap-2.2.6.7.tar.gz 54055 SHA256 89601cb351681e7cdc621c2aa9d8788d180d2f16f6d341f55f513c489af8701a SHA512 8b9ee3fbbe15777f050f067be29a8d4e8e8b58aa8b430f69330da262593808838c8e0b3946a6f7932dc5d4d1b9dad12be73b98f82a6c399f7383f2630ad6ce47 WHIRLPOOL f5f055bfa3f303643ac0593a972b732f4b431284e8c959c49ca3e41182d3a8b0bfb844ba9471318308a54408fb08ee19525679c0d9460ce29753ecc616883894
+EBUILD dap-2.2.6.7-r1.ebuild 922 SHA256 66b8d459671c78eeca0f328ed2169f6c45ed6596a9bfc72c43acd5309f070a2a SHA512 76b501d3d308f64cd15a26044687a99fe47e1586bdcb15fc19a261359b1de0958c492f660f9c96b9da838d9b458aa193e58b7511d4d09beb5712638fa31d4af9 WHIRLPOOL c8389f682569a566d1fb4e698f65c35aaa66f96432de29ecd80f3883036c6075837e2b9884009322bd9696a78257059a6c2b9dd3dfa423398b50016d51c4e11a
+MISC ChangeLog 2571 SHA256 4d3c3fc569004f2035111b801f9f39554b813c688d774919631718741de84bfa SHA512 a3310fc407f361805215bf3efbbf7284320a5684a34a35b009e1d6ce07d84cac3ea05d3d9c1fe8b30c30df476715709066c3981e51bec83b037923975cbf6a5c WHIRLPOOL ef17c0ce86eddbf5caeefd680e5efd6045c5512d2b8c37225ae9480777bf83b7d9a1efc83b6132d5ec598c02664e32be514a8a553ab688a8746c2f7325c722d9
+MISC ChangeLog-2015 2103 SHA256 b226509a8161ea878497c6d50acab371d39a6f1165c30c08c60e428a38a732e3 SHA512 f5c53df44da1b27dbba57bf51fcf76857b60a148619aed8eb7dbe8dfd66bd19e317285c5578682d98f2eef8cc42a44892c856644a3c6e598049c59ca05b18184 WHIRLPOOL 9e6a89b8ceb51ef186dadeef5d20df44085c679de0d9ff41ca77fe3a4fae87f4390bfa76257add837a945c5a5db1437b5e2b24d9e38f9131a77c428e45e60f99
+MISC metadata.xml 785 SHA256 c0743306161c2bb195bbaa11b6866bed87eb840170e6d0a3d6cf17780dfb1707 SHA512 6ceab6d92c0b6a1ca339deba49015878602727c795e4a63d24dcf81dfe4456b0fc6c20876a6a35a5052172e0b7dd3f2b1271eb8682d2b3f13fb0f098327cdf9f WHIRLPOOL b00c8e6c6c2292495fba230bbfa1cb0c5f30db9a03e7d92a56d3ba4f12775cb133a6532ddf15dd4af2ad242bfdcb9a599db557b2875d9c379620b19770c821cb
diff --git a/dev-python/dap/dap-2.2.6.7-r1.ebuild b/dev-python/dap/dap-2.2.6.7-r1.ebuild
new file mode 100644
index 000000000000..cc9a0959438a
--- /dev/null
+++ b/dev-python/dap/dap-2.2.6.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Data Access Protocol client and server"
+HOMEPAGE="http://pydap.org https://pypi.python.org/pypi/dap https://pypi.python.org/pypi/Pydap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="server"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
+ server? (
+ dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/pastescript[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/bugs docs/Changelog docs/history README TODO )
+
+src_prepare() {
+ sed -e "s/'dap.plugins'/'dap', 'dap.plugins'/" -i setup.py || die "sed failed"
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/dap/metadata.xml b/dev-python/dap/metadata.xml
new file mode 100644
index 000000000000..34ec26873bae
--- /dev/null
+++ b/dev-python/dap/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="server">Enable OpenDAP server support</flag>
+ </use>
+ <longdescription lang="en">pydap is a Python implementation of the Data Access Protocol
+ a.k.a. DODS or OPeNDAP. Using pydap as a client you can access
+ hundreds of scientific datasets. You can also use it to serve your
+ data from a variety of formats.</longdescription>
+ <upstream>
+ <remote-id type="pypi">dap</remote-id>
+ </upstream>
+</pkgmetadata>