summaryrefslogtreecommitdiff
path: root/dev-python/d2to1/d2to1-0.2.12_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/d2to1/d2to1-0.2.12_p1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/d2to1/d2to1-0.2.12_p1.ebuild')
-rw-r--r--dev-python/d2to1/d2to1-0.2.12_p1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/d2to1/d2to1-0.2.12_p1.ebuild b/dev-python/d2to1/d2to1-0.2.12_p1.ebuild
deleted file mode 100644
index 8d555a022c0a..000000000000
--- a/dev-python/d2to1/d2to1-0.2.12_p1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-MY_P="${P/_p/.post}"
-
-DESCRIPTION="Allows using distutils2-like setup.cfg files for a package metadata"
-HOMEPAGE="https://pypi.org/project/d2to1/ https://github.com/embray/d2to1"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
- rm ${PN}/extern/six.py || die
- cat > ${PN}/extern/__init__.py <<- EOF
- import six
- EOF
- sed \
- -e 's:.extern.six:six:g' \
- -i ${PN}/*py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}