summaryrefslogtreecommitdiff
path: root/dev-python/cython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/cython
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest2
-rw-r--r--dev-python/cython/cython-0.29.22.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index dfed1632b5d9..9cc34908b759 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -2,6 +2,8 @@ AUX 50cython-gentoo.el 388 BLAKE2B 5bc38190b467efa9e7be1a5831022534dbfdc02206fca
AUX cython-0.29.14-sphinx-update.patch 377 BLAKE2B 32ba9ccc6c093fb9e575686c9a3b707a10a2488979d0a1dcc0863022d48255455216d11c1968bc5d49a8b583a340113c090ec103ae233dcac2164beb1765f9cc SHA512 3714019a1659b69243bf5f76d1557e3e4e507fa6b15bf4259001f961d1127e18e01e3d17fe04706c882e264651ea5699c6295f33c66af7577ab6e0906c0d3273
AUX cython-0.29.21-spawn-multiprocessing.patch 1096 BLAKE2B f31e9e8bdc86ab1098bfa115e60470410f41fdf4be558c6a11d0c3ea61b8a8009f6242a96e2574f525e53b6125de78c5f8dbd8f7499d8debd368e80a6d383e47 SHA512 71f2349dfee2504bffe2ce378a00b2033ad229f99c597382eafa54107fbdc56fc177e4412e6314794b5ce22d9713e535467b0ed3e36ae657a5deb9c3325eb242
DIST cython-0.29.21.gh.tar.gz 2088511 BLAKE2B 7a4ddabb65a519d3c71454ac8417438a3a9c46b47489c18e7c7e82ffcb5d5f2f0c5246d0b364f8317d374c53f0c83844c73c7d2ef6b9f75f10707aaf2931ce41 SHA512 2c0c3e3fff07106eb98862f71cd5dec9ff29460cf9b9e4de74537ca5e033f7523989beb5fbdc14723beaf94a535976f75c803e791b87e017961d9694b8c37679
+DIST cython-0.29.22.gh.tar.gz 2091955 BLAKE2B 8225fa6073d43de1e44e8cd22d52f9bde5d3b6e6e766c74d5ef18d77b57c0e1b22a21cae5b133b0b22f7207aa51dc0e76f1073db977190d42c2b55cc2d7e148e SHA512 b7f22112678f159bf1d0ad5fe4f7c103e96f240bab4d9dc07edd7c2f66a9887b9af72b32f1d5886361b48d428bc2b9499d3c5b59ce5af1068f20a26549783dd6
EBUILD cython-0.29.21-r1.ebuild 1792 BLAKE2B 03fbab5e328ff2dba249e6a5bf17abdb4fe69217f3527a89c4920d78129bc4a40b267ac58f8eb70deddd432ea34538a44254e1a71931f7263fae8d3761b9c1a2 SHA512 7b0240e6ff14f2cf12e54deaf025cbb4c72984a351541b646234091159c0a4e2305339cd6a58f64b756a9f99aa39fee3e9b326127e5bcf98ccca5de26d9bdf3a
EBUILD cython-0.29.21.ebuild 1987 BLAKE2B 1df83b6ef7f839622cd73c07384ccf0a6e722fe5ae9f42374ff9df2995e5b624e78a534c078534c341d034f984f73fc5c3abe954166ba8ef0f3fcc6aff2fbf06 SHA512 aa85e5d5ea9a1413686d8903af4c2c310f504ba0fc1ca469253010dae7a2abbb434b5d2e59f18b1a22f1149cfaade4b942466973e9559b913146abdf3b191155
+EBUILD cython-0.29.22.ebuild 1796 BLAKE2B eb33c0156b5e9a19faab496091632de2e6ffecbfec83e756b493b302b2e850d28aed7bcea7190d69bbaa2d2fc09c61d1b2c0e13d5d6062f3e16fe0299067fdd1 SHA512 b7fad08575a5c2e966416019174fb412355c7bc178433c42bc60a115528004d8e901d2878a2bc494e5d55a6717c161f434081cfe8f294f1a55ffe039bdf5ca84
MISC metadata.xml 605 BLAKE2B 900f2ffaa501d7ce5bef46115f7fdbda0966bf4ae048b4c27ac4be06e1b23de17c674e27f97627aed8d1d65b52bea01532d8a698bdbcd20b7c9fab4bad278b16 SHA512 66176bb6e00f70b610a41bfbc973bae2b4b8b9aeeeb6bdc9e14c2832d513d5452aec6509f8225daffb7e169d93311a4ccb026c935ead80ffeb35d91f1ae558fe
diff --git a/dev-python/cython/cython-0.29.22.ebuild b/dev-python/cython/cython-0.29.22.ebuild
new file mode 100644
index 000000000000..137bf8549e56
--- /dev/null
+++ b/dev-python/cython/cython-0.29.22.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs elisp-common
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
+ https://github.com/cython/cython"
+SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="emacs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+BDEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
+ 'python3*')
+ )"
+
+PATCHES=(
+ "${FILESDIR}/cython-0.29.14-sphinx-update.patch"
+)
+
+SITEFILE=50cython-gentoo.el
+
+distutils_enable_sphinx docs
+
+python_compile() {
+ # Python gets confused when it is in sys.path before build.
+ local -x PYTHONPATH=
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use emacs && elisp-compile Tools/cython-mode.el
+}
+
+python_test() {
+ tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.rst ToDo.txt USAGE.txt )
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} Tools/cython-mode.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}