summaryrefslogtreecommitdiff
path: root/dev-python/cython/cython-0.25.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/cython/cython-0.25.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cython/cython-0.25.2.ebuild')
-rw-r--r--dev-python/cython/cython-0.25.2.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/cython/cython-0.25.2.ebuild b/dev-python/cython/cython-0.25.2.ebuild
deleted file mode 100644
index a7431480936c..000000000000
--- a/dev-python/cython/cython-0.25.2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs elisp-common
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/}"
-
-DESCRIPTION="A Python to C compiler"
-HOMEPAGE="http://cython.org https://pypi.org/project/Cython/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE="doc emacs test"
-
-RDEPEND="
- emacs? ( virtual/emacs )
-"
-# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
-# spanning several packages. This bug has been fixed in the recent release of version 9.1
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-SITEFILE=50cython-gentoo.el
-S="${WORKDIR}/${MY_PN}-${PV%_*}"
-
-PATCHES=(
- "${FILESDIR}"/0.25.2-test-cpdef_enums-L-suffix.patch
-)
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS}"
- local CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- # Python gets confused when it is in sys.path before build.
- local PYTHONPATH=
- export PYTHONPATH
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use emacs && elisp-compile Tools/cython-mode.el
-
- use doc && unset XDG_CONFIG_HOME && emake -C docs html
-}
-
-python_test() {
- tc-export CC
- "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} Tools/cython-mode.*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}