summaryrefslogtreecommitdiff
path: root/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild')
-rw-r--r--dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild
new file mode 100644
index 000000000000..ba44a82f8fd0
--- /dev/null
+++ b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="A trivial extension that just raises an exception (for testing)"
+HOMEPAGE="
+ https://pypi.org/project/cython-test-exception-raiser/
+ https://github.com/twisted/cython-test-exception-raiser/"
+SRC_URI="
+ https://github.com/twisted/cython-test-exception-raiser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"