summaryrefslogtreecommitdiff
path: root/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild')
-rw-r--r--dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild
new file mode 100644
index 000000000000..f76e3e4f96bb
--- /dev/null
+++ b/dev-python/cython-test-exception-raiser/cython-test-exception-raiser-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A trivial extension that just raises an exception (for testing)"
+HOMEPAGE="
+ https://pypi.org/project/cython-test-exception-raiser/
+ https://github.com/twisted/cython-test-exception-raiser/"
+SRC_URI="
+ https://github.com/twisted/cython-test-exception-raiser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"