summaryrefslogtreecommitdiff
path: root/dev-python/cwcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-17 20:33:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-17 20:33:10 +0100
commit1c9a2b6cf059fca455a527c1bd76a2321f93b310 (patch)
tree1b35cf6afe711f7eaedfe2e5fe41b14e517ee215 /dev-python/cwcwidth
parentb9d1ad143f4a37061059ce69b1251e23fd760f95 (diff)
gentoo auto-resync : 17:08:2022 - 20:33:10
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest2
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.7.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
index bed0e3680fca..4aed69e82d7e 100644
--- a/dev-python/cwcwidth/Manifest
+++ b/dev-python/cwcwidth/Manifest
@@ -1,3 +1,5 @@
DIST cwcwidth-0.1.6.gh.tar.gz 11563 BLAKE2B 014c1ae377005c704620fda7063e9891c014bb3f3f22160baf55cbef6e07084302a34ccea6bce2ca0f06d193ed3782006e308930a19c9a3c02bf181070eb5654 SHA512 0516fd49d625cd4bec26c27fd2fbbde55ca13a92bee3712018627a5c7f7a0c04aa06842ecce4c99d468f262a829f4ec5ff20bbc66232ad0fc037a7ade5845622
+DIST cwcwidth-0.1.7.gh.tar.gz 11282 BLAKE2B 20be2d54aceabc02a12fadc0cdee6e53037480fcc01be3b08b0ec69ccd515cdbe91a9024ea29e6dbd0d4c927ae0a32dd7debcc07815a9f2053a9ef6a5d5a0d7b SHA512 b81b1ccdce44e8e11d55258752a20e25a76452b3f0324e6168d89a5dfce706e0dd9dd28096234fcea4c38f619a41518dd7fe249552f7e27f77d383074001e468
EBUILD cwcwidth-0.1.6-r1.ebuild 616 BLAKE2B 02de2b540ac876120fcaf6885328724248a7078182f1349fdeb4762ae51f7660203a01f1029740c64d95ce576cf0a0d4b24e37caeab5312f4894e1a517c87dca SHA512 c06bb527dda61e542d91f265b255e1d527b13c24fb3dbdbd9f1635caba1e269a9656c1bad25d72ab54c9859e968084ebe7dfb51026a6dd378bbefe37be0d0b75
+EBUILD cwcwidth-0.1.7.ebuild 618 BLAKE2B b2fcc726dd54ecd3889428202f45b0f495f4e00aa78dac3eadb962f4c405c72c59ea059b6ca8be3a7b79c96fcdeca3a01287680ab34c89fdb7f2adcf10b5f6af SHA512 68fb6ba61fa7f24e83d52beac02be448eb08d403adf97998559172a0355a47e370b5dea3758a5e0d5ffdd140031b14279dd5a406f7c96b1d867dd895525d4852
MISC metadata.xml 349 BLAKE2B e1564185d34e24bd6070ffe534ded26aee31004f72bdcb85e27b6d42d243e7db1a9db68e75a6678c9da59530457d34a8cf58be54d919d18ddc539461e03992bc SHA512 65af1da9bc2295a6395395a832288b493df2218a85d8289361c05f2b0ee1bba57a3d32edf09a6c29e691dc43e4a92b34bc8980d346e7b860c5562a238731c067
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild
new file mode 100644
index 000000000000..b667006da87e
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}