summaryrefslogtreecommitdiff
path: root/dev-python/cwcwidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /dev-python/cwcwidth
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'dev-python/cwcwidth')
-rw-r--r--dev-python/cwcwidth/Manifest2
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.6.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
index 7acc768ae6e5..fabace266a3b 100644
--- a/dev-python/cwcwidth/Manifest
+++ b/dev-python/cwcwidth/Manifest
@@ -1,3 +1,5 @@
DIST cwcwidth-0.1.5.gh.tar.gz 11526 BLAKE2B a457a17ad3668b0633c8aebd8b015225a37afdb9f45a9342960716583e57f7e0d6cf80f27d6139f339e4876d9f8fa4b4cb7c03bb92a6d9ade99225900b8d4a36 SHA512 2eac36232f1efbe427290c3c1d356ab1a31c4d855a0755eed71b18e3c93f516890dd592643efa8a59551fb5e997e39afd5aca7bd0dbe24d4552de738fb2e39ba
+DIST cwcwidth-0.1.6.gh.tar.gz 11563 BLAKE2B 014c1ae377005c704620fda7063e9891c014bb3f3f22160baf55cbef6e07084302a34ccea6bce2ca0f06d193ed3782006e308930a19c9a3c02bf181070eb5654 SHA512 0516fd49d625cd4bec26c27fd2fbbde55ca13a92bee3712018627a5c7f7a0c04aa06842ecce4c99d468f262a829f4ec5ff20bbc66232ad0fc037a7ade5845622
EBUILD cwcwidth-0.1.5.ebuild 574 BLAKE2B ff74e09096fde1d5a7f9fe3098ebb816795c7b9a142e336dcfe42bbde444e7f7b583f0965bcfdbd9c0ae8261db2de91228c48fb56bd884589b7a950a7ae4018f SHA512 23b33e23a429a301f6793c50aaa7e5028801d785d48811b080e7b9866ccf4d89e2a03bb3dc0e7d2ad3a75f0368ac7a8afcda6ae6c94c5bd1b9b51feea6947cb5
+EBUILD cwcwidth-0.1.6.ebuild 574 BLAKE2B 5fb3b7f9300de6ad43d9fca92a2adb647b3eec9d6acf29a1b0b9d6d6ce085be18b299a33199ddeb69cc3e5debdddcd9d468d2b42ef2c38c2dc3c7f050223ab3e SHA512 c6e3c86f8f9ec666a1998619d90f55d1ab2dde9cb753bafdd931a0990ed2606d0ef57848de77482241c115167b40b6e0dc29d3647a94f1e83b993fc7325229b8
MISC metadata.xml 349 BLAKE2B e1564185d34e24bd6070ffe534ded26aee31004f72bdcb85e27b6d42d243e7db1a9db68e75a6678c9da59530457d34a8cf58be54d919d18ddc539461e03992bc SHA512 65af1da9bc2295a6395395a832288b493df2218a85d8289361c05f2b0ee1bba57a3d32edf09a6c29e691dc43e4a92b34bc8980d346e7b860c5562a238731c067
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild
new file mode 100644
index 000000000000..a7b0fb7a42b8
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}