summaryrefslogtreecommitdiff
path: root/dev-python/cursive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/cursive
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/cursive')
-rw-r--r--dev-python/cursive/Manifest5
-rw-r--r--dev-python/cursive/cursive-0.2.2-r1.ebuild28
-rw-r--r--dev-python/cursive/cursive-0.2.2.ebuild10
-rw-r--r--dev-python/cursive/metadata.xml1
4 files changed, 36 insertions, 8 deletions
diff --git a/dev-python/cursive/Manifest b/dev-python/cursive/Manifest
index 6d490d31d079..388abddbce64 100644
--- a/dev-python/cursive/Manifest
+++ b/dev-python/cursive/Manifest
@@ -1,3 +1,4 @@
DIST cursive-0.2.2.tar.gz 43065 BLAKE2B 2c007b357c3cd1d560f74958b78d157c97301b8c2e15ed50ff340950eb4abb8baac078865bd82a3222a22505862a78a651905c843b6b0ba4662d653dfdd5f369 SHA512 6c97f8f71b016ee57349b8156543c8ca41c29c3f234ea60967b96c09fce2cea4b36b9f92996c622bd9504d4a71893903e8d5a8ab50e089fd37bddb8095f4b9d2
-EBUILD cursive-0.2.2.ebuild 934 BLAKE2B 5a9a3797ac27efde9ed5294b625f948c20776c7c46260ba45e778d01ee1c73c3d6ac77f1ebd599ff7ea859b583b254f0d7355b3027b41d44ff7b38d84ac9d753 SHA512 ea751234fa50dad065f7bca45c6b5fccb33442bde0f6f3095cc0c09ae3264bbaa7545bffc6c03e30304bc68a0cc5e87a42e66d17aa13da85a44083bd3f831708
-MISC metadata.xml 506 BLAKE2B 5f2e3c604b20bd4f8c17efa4ca257497623af95891e9da873dc5b06de8e6f10be1f6b4bdfb341ea6b0bbe722b935ca68551f217b1751541e311ae65eb889a565 SHA512 6abaf6ce58fd7291e5930324a69581abef02af29f7ff2f8a21138efce7c310fde46da2286a994d74083d248fffb3194d38867733eeeaaa78e70d7db1726fa4d2
+EBUILD cursive-0.2.2-r1.ebuild 901 BLAKE2B 4477ba05023cf591e9c830b9af892b7d45763ed4bffa6476edde4cd11cd8eb88e05befcc557d9c63079db57f09cc5072afc4f7d34e69b61b9e577adc49361f2e SHA512 a5d2525ff820f7a6df85abcace17d03065233bfa55a0b76018852a776666fdf2502020550871fe6ed7638fd8a25d996328a38797fadafaeaa3a971ddeb3b24c4
+EBUILD cursive-0.2.2.ebuild 899 BLAKE2B 8019e27fa31e3ef0fec1731789af05dd3d170675d1499f34c663f11b3ad40e1314cd0fc07f5683216826cda3bc6a70cad5d2c5321074d3cccc99332732c347cb SHA512 6053ccf5d7862db54b9e1e0a9576bbf4924b166d6de5355bdca75206eeb4174c25ab25713f07ae5266c153b7d71731b14ecaf77a38a8b01dfd6f55189119ae10
+MISC metadata.xml 531 BLAKE2B 2d1b19c291e6497c949cf9ea099b5246733eaab4a91fcd7f5a4801d3fd48caf6ca0d1c90f6235778057f417d70e47586de3e0921b455ea9e40d76efce7230c5e SHA512 32918281cadbf14c3310426a34593638198b873cf03550fbc7b5f4233385f6cf58fcfd7c2b44606ce243d6618a15c9911938037cf42b8ef05538324b3a569638
diff --git a/dev-python/cursive/cursive-0.2.2-r1.ebuild b/dev-python/cursive/cursive-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..737826a40925
--- /dev/null
+++ b/dev-python/cursive/cursive-0.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/cursive/cursive-0.2.2.ebuild b/dev-python/cursive/cursive-0.2.2.ebuild
index f2b44124535c..6b0f389fe263 100644
--- a/dev-python/cursive/cursive-0.2.2.ebuild
+++ b/dev-python/cursive/cursive-0.2.2.ebuild
@@ -15,16 +15,14 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE=""
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
- >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/cursive/metadata.xml b/dev-python/cursive/metadata.xml
index 90971ef21590..1cfc5fcaf17f 100644
--- a/dev-python/cursive/metadata.xml
+++ b/dev-python/cursive/metadata.xml
@@ -9,6 +9,7 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">cursive</remote-id>
<remote-id type="github">openstack/cursive</remote-id>