summaryrefslogtreecommitdiff
path: root/dev-python/cursive
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/cursive
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/cursive')
-rw-r--r--dev-python/cursive/Manifest7
-rw-r--r--dev-python/cursive/cursive-0.1.1.ebuild32
-rw-r--r--dev-python/cursive/cursive-0.1.2.ebuild33
-rw-r--r--dev-python/cursive/cursive-0.2.1.ebuild33
-rw-r--r--dev-python/cursive/metadata.xml19
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-python/cursive/Manifest b/dev-python/cursive/Manifest
new file mode 100644
index 000000000000..9acf13492ddd
--- /dev/null
+++ b/dev-python/cursive/Manifest
@@ -0,0 +1,7 @@
+DIST cursive-0.1.1.tar.gz 18522 BLAKE2B f2239747b6f4b033c2230b47c477ee9121a705dc032e83f02569e7cd37c5330c37b8aef999b1943152906aa73995e49a34a6e9b7d8ab8dcde75601e5a87ca665 SHA512 3a6ae804c010ae2b596eac8fbc3c9be6d7994ea8984513617f1eaa7c77c8335ce2c36419d8e6acadb305210d96d51ead8470a79e8425f2c00ef0dc9ead59929b
+DIST cursive-0.1.2.tar.gz 18620 BLAKE2B 058a15d9fc7b0e23318da903ad25b6e3b5efec56fedcead1a2016147a1ebe94ec20ceea7c4bd4ee0424b56d919b5d5ede6748ef4f8125c99a4b9c654f02c32b3 SHA512 e8957df9de252435a534bef3b84c6b96de369036515e74614433f4d270aa8cb0bc4f467591a839ddb3b5f76ab7f302b18d6af5f79c7554f027a3cfb4e0571fba
+DIST cursive-0.2.1.tar.gz 40334 BLAKE2B 9d90793d4cfb63ae9f4f6bbe8628a7130b3b9658f98b044f0cbb60720c70e3abe4a34773ce3e4100d4bfa9c81e25cdbd215d8752306fba13abe5e811412aacd2 SHA512 70d16d27cba944946579821e3669a17a72b2d5cc1b026427e5a09d0385e08afb7cd7ea3c3cd180d3bc8f3e7b58772e1055e193d06cb57a58e1c83d1230c62c23
+EBUILD cursive-0.1.1.ebuild 1037 BLAKE2B 7ea604c3540374b9f8b32750ed20f4b128e284a7c10aca219a7174b9c13e4d7315709169ec0eb35487213b390f04a549f213e4e45977613c493883d8fbb0f338 SHA512 0a6ee0f9e349c1c16ab65a6c404f479d64a85970f750d8a8b476b0f90186eae3c0886a0963dde41017d09e16bf82cd3dec67b9d33830b7db8057708775063942
+EBUILD cursive-0.1.2.ebuild 1085 BLAKE2B 18c9c552035717a7c0f76b6cdd0ce47a1e455bf9b7ca931a951fe7e344fe0c78712b44f4562acbff5a4943663f8c02955f7683fdac6201714702a3a95bed2824 SHA512 a39541d510d607dc00d5c4c8bd2420e8ddc77384c07e63380c7e97a246db0c054dfe867da72b0703d85faf36dd9b15c2ef320ee736d962260e61307e3ec5d32c
+EBUILD cursive-0.2.1.ebuild 1081 BLAKE2B 98bb768cf421293a80d570b0198af44dc65732a9b54daa1fed76454dc09ba5471e4b6dbdf42c90048b091fb84b0e9ca1f4262a575a108d83c57c417a47baac41 SHA512 5fe74935bd300e76b225260dc9455c38b824436ee81c3b7c39c4a77516cecc053fb2040a5ec807e3f6c51de82f31ef3e079db13fc96a3609e12a2c5980e92170
+MISC metadata.xml 633 BLAKE2B 7b363a0b8ced131965cfbe2616dd30d3608d3d61b1c402b1885eea0e10c379e5d82e87e15abe1d805349ad2d99b94a2c2ebc2df7e8df7a5a095a4fffdd174c52 SHA512 0ab2f1ce6ef8d6e2a53a9dad20c26a26beddb6738857e3cd360362e0c1ad1c562eca6551cc88bb8ad4a8e08f621224934a4476b1ff22aee805dfe6f1ce352c6c
diff --git a/dev-python/cursive/cursive-0.1.1.ebuild b/dev-python/cursive/cursive-0.1.1.ebuild
new file mode 100644
index 000000000000..10c5464071a6
--- /dev/null
+++ b/dev-python/cursive/cursive-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/cursive/cursive-0.1.2.ebuild b/dev-python/cursive/cursive-0.1.2.ebuild
new file mode 100644
index 000000000000..a3cfaf8f9e62
--- /dev/null
+++ b/dev-python/cursive/cursive-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/cursive/cursive-0.2.1.ebuild b/dev-python/cursive/cursive-0.2.1.ebuild
new file mode 100644
index 000000000000..96d307dd8f0c
--- /dev/null
+++ b/dev-python/cursive/cursive-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures."
+HOMEPAGE="https://github.com/openstack/cursive"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/cursive/metadata.xml b/dev-python/cursive/metadata.xml
new file mode 100644
index 000000000000..c1128eadb030
--- /dev/null
+++ b/dev-python/cursive/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cursive implements OpenStack-specific validation of digital signatures.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">cursive</remote-id>
+ <remote-id type="github">openstack/cursive</remote-id>
+ </upstream>
+</pkgmetadata>