summaryrefslogtreecommitdiff
path: root/dev-python/ctypescrypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/ctypescrypto
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/ctypescrypto')
-rw-r--r--dev-python/ctypescrypto/Manifest4
-rw-r--r--dev-python/ctypescrypto/ctypescrypto-0.5.ebuild41
-rw-r--r--dev-python/ctypescrypto/ctypescrypto-9999.ebuild41
-rw-r--r--dev-python/ctypescrypto/metadata.xml17
4 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/ctypescrypto/Manifest b/dev-python/ctypescrypto/Manifest
deleted file mode 100644
index e90b777cc99e..000000000000
--- a/dev-python/ctypescrypto/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST ctypescrypto-0.5.tar.gz 44667 BLAKE2B abf24a4a5dc5ea1d977427f781e44433aaeac716b4f1f8d6f23e7f8de7debae75cfff80e72c369b64b8b9299f4b058763d42c5f21cd499f9b5689481afa5a538 SHA512 96ca12145be503a5b343d936cde172039057e5a2308fb6f6f65e14fe859d4e98d93ffb996849e391cf0c474425ee6243fd4c7998b088938a21456965d135188f
-EBUILD ctypescrypto-0.5.ebuild 1061 BLAKE2B b16c510e4f95c59ca321fc161b8b9958534424c66a2a02a11d167f304f68c7f62b065a1ed4d5ed2117a7b52c742d7413ea9572cf422796e7298676900b9ee5d9 SHA512 d4088c7da89e8289c5e5112af4edfce10f0f67a3ad4f5c82a67a16c1b95c0b7fa4f48a37d964ad5104c752e7762cf30a1918a7d25624d0d1e062b257a1c79166
-EBUILD ctypescrypto-9999.ebuild 1061 BLAKE2B b16c510e4f95c59ca321fc161b8b9958534424c66a2a02a11d167f304f68c7f62b065a1ed4d5ed2117a7b52c742d7413ea9572cf422796e7298676900b9ee5d9 SHA512 d4088c7da89e8289c5e5112af4edfce10f0f67a3ad4f5c82a67a16c1b95c0b7fa4f48a37d964ad5104c752e7762cf30a1918a7d25624d0d1e062b257a1c79166
-MISC metadata.xml 500 BLAKE2B 8d2b7bbb526d176ab07c28253f91966ff7b73e9e9ab4e6142aeae9b1138543e256eebd69b3ed97f038a68c65d756c8933dc978614fb11918cf44ee753b0c1a42 SHA512 d663565973b7f56953b790f36f18e95ca8db626422a9229a824a64c78f80e9b9dfa4794c65532e75a88dc81e4333f895d590c740f0ef8fe0e209a53960fa4de1
diff --git a/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild b/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
deleted file mode 100644
index 2c7dccb1cf8e..000000000000
--- a/dev-python/ctypescrypto/ctypescrypto-0.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to some openssl function based on ctypes module"
-HOMEPAGE="https://github.com/vbwagner/ctypescrypto"
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/vbwagner/ctypescrypto.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/vbwagner/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="gost test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( gost )"
-
-RDEPEND="gost? ( dev-libs/gost-engine:= )"
-
-python_prepare_all() {
- # Remove failed tests
- rm tests/testpkey.py || die "rm failed"
- # Disable test
- sed -i '/test_verify_by_filestore/i\\ @unittest.skip("disable")' \
- tests/testx509.py || die "sed failed for tests/testx509.py"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover -v tests || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/ctypescrypto/ctypescrypto-9999.ebuild b/dev-python/ctypescrypto/ctypescrypto-9999.ebuild
deleted file mode 100644
index 2c7dccb1cf8e..000000000000
--- a/dev-python/ctypescrypto/ctypescrypto-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to some openssl function based on ctypes module"
-HOMEPAGE="https://github.com/vbwagner/ctypescrypto"
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/vbwagner/ctypescrypto.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/vbwagner/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="gost test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( gost )"
-
-RDEPEND="gost? ( dev-libs/gost-engine:= )"
-
-python_prepare_all() {
- # Remove failed tests
- rm tests/testpkey.py || die "rm failed"
- # Disable test
- sed -i '/test_verify_by_filestore/i\\ @unittest.skip("disable")' \
- tests/testx509.py || die "sed failed for tests/testx509.py"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover -v tests || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/ctypescrypto/metadata.xml b/dev-python/ctypescrypto/metadata.xml
deleted file mode 100644
index 2c5497fce84f..000000000000
--- a/dev-python/ctypescrypto/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>zerochaos@gentoo.org</email>
- <name>Rick Farina</name>
- </maintainer>
- <use>
- <flag name="gost">Build with support for GOST Message Authentication Code</flag>
- </use>
- <upstream>
- <remote-id type="pypi">ctypescrypto</remote-id>
- </upstream>
-</pkgmetadata>