summaryrefslogtreecommitdiff
path: root/dev-python/csvkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/csvkit
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/csvkit')
-rw-r--r--dev-python/csvkit/Manifest2
-rw-r--r--dev-python/csvkit/csvkit-1.1.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/csvkit/Manifest b/dev-python/csvkit/Manifest
index 63c7f65259dd..d748a845d2da 100644
--- a/dev-python/csvkit/Manifest
+++ b/dev-python/csvkit/Manifest
@@ -1,3 +1,5 @@
DIST csvkit-1.0.7.tar.gz 3792335 BLAKE2B 6a9c5c1287648271eacf5f010a4b181f5e997a52d196ac4b73b95723e5ce2a3d90d0b51fe4f597b0b346292cefc16b7c283b02e9a8e56f26e10bca9b3f8622ea SHA512 c6275ed000639a1ddf15246eb1e0198787f832537a284900067e3ec65986be115709b3fd4aaf8e13a9b53160edd57ebb864ee1e73354712591c78297b6d293b7
+DIST csvkit-1.1.0.tar.gz 3791940 BLAKE2B 9ef69f1acde1cab9ed69ca62b8e94fc92207bba1967db17c4f2edbda7191d2783d075be004d5c6022d446921343938ed502812602b2ce1cb16c2c62b530a5027 SHA512 4cc9eb9c326bc38368149721777f0c14e89fa8e65b7553908120613ee233105a6ab324054382766c6838c1594960907373f59b33a285e92a62b6e6cd0f5f89b7
EBUILD csvkit-1.0.7.ebuild 865 BLAKE2B 53cc6dc8796d508c340a267efa1e5634823dfc54912880f40fec5528bd5a74a9a774b853682bb4bd9db2315529ebf2ac66a04698bf216865b5dd715a1d5c5fe0 SHA512 b159f33d4b267248c2e6a2182e2140576580fa41ff109f71f73facf911da97b8855a9cefc8d38d74f96020a8f3d7e9657debeeaee0082f54329ffc7246c12378
+EBUILD csvkit-1.1.0.ebuild 959 BLAKE2B 1bd231db411c950756cffc1da504e87e64d36aba46b14db70fcd97ff2f0771026904659d4bfc057759e534401f5f959cc8870d1e807311a471e0444517f26de6 SHA512 8f8eb29392c8e4f205b99d3435e26a6a8fff9d76d32d0ced5f5ced693f318b4d87cd8e125f5ab04a1920efca2c89aec1e849ba51c3c37ac63c01b89d42c3ad09
MISC metadata.xml 626 BLAKE2B 181917319a1f5bfd6356b2fb06f91892d2432f9ae29a5586c9a6d9579747a676a42d3ee94c1601b53f8ba5c3fc9bbf162b6b3b419ccbc047ead3f1120c2bd056 SHA512 23194fc2a805904809e1df179572fe8e52344b58bda98f064a5221b3637f21f9f8f974e466e65353915b7eb9c66ae23464d1c79e92829147a7c64c6999963f56
diff --git a/dev-python/csvkit/csvkit-1.1.0.ebuild b/dev-python/csvkit/csvkit-1.1.0.ebuild
new file mode 100644
index 000000000000..e820e8cd9f6e
--- /dev/null
+++ b/dev-python/csvkit/csvkit-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A suite of utilities for converting to and working with CSV"
+HOMEPAGE="
+ https://github.com/wireservice/csvkit/
+ https://pypi.org/project/csvkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/agate-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/agate-excel-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/agate-dbf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/agate-sql-0.5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails depending on locale, let's not force en_US
+ tests/test_utilities/test_csvstat.py::TestCSVStat::test_decimal_format
+ )
+ local -x LC_ALL=C.UTF-8
+ epytest
+}