summaryrefslogtreecommitdiff
path: root/dev-python/csvkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 23:52:39 +0100
commit1b2c0d19f75523db182b267901484f87abf732cf (patch)
tree3c4832e97c3846189d07c64c2eba333bf33b8ab2 /dev-python/csvkit
parentdd851ab76c56a249df7a0ec052acd90940bc014f (diff)
gentoo auto-resync : 04:10:2023 - 23:52:39
Diffstat (limited to 'dev-python/csvkit')
-rw-r--r--dev-python/csvkit/Manifest2
-rw-r--r--dev-python/csvkit/csvkit-1.2.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/csvkit/Manifest b/dev-python/csvkit/Manifest
index f63def34ae5a..e5d4231a5b3e 100644
--- a/dev-python/csvkit/Manifest
+++ b/dev-python/csvkit/Manifest
@@ -1,3 +1,5 @@
DIST csvkit-1.1.1.tar.gz 3792699 BLAKE2B 730dad274fd873af6903f815a6d2a7dc70d48a845347be644e573fe2772f53786cbf20a631bd8a7c81ffeac03c92f00607be582fda4cd1b6a7efe93d30070182 SHA512 16825ba629ba39022c7537c210f0c5e51f7b03c0552a16fd57b86b0cfd9ff883937d5be21a1a7ef583cf94ea56bff37de259684c84a50d5e9c3ec10f8a5f33dd
+DIST csvkit-1.2.0.tar.gz 3792364 BLAKE2B b5d26afc485fdfdd03d1b3036bb6f24dff63568333fb262bcab3086f546cfb72b6981d520d531219a01a4d99357d8067d1676779ff6be116f08724c1f6ac0faf SHA512 3b59908e5c8afa5be2a71940ef9e04f9c55ab4703ca7827bb68975a1c43584797e75edcf3a6ea4861ca5214fbe45e11fd84560bb05f314508040dcde513f6178
EBUILD csvkit-1.1.1.ebuild 935 BLAKE2B 50a5aab425117c391777613f45463136ea093a1d7da594cc85059840e9c509c08df4012e76f2168400ee6e6b25a5890a270fde9357025cf715d9b7d509990bae SHA512 d6b552229228c678e684ed3a198e331590805680888fd6c2dd8663a57bd01b0ff270e47918b9d8270154e85fd9d9942c5ba208c9042df857e5b59c62e472c957
+EBUILD csvkit-1.2.0.ebuild 1051 BLAKE2B 01db6c44a70f7ab59915a616276bba82b54f6a7b8c7139d4d9e374bc4c0e52893fcfc3d127b3f600edebff3a4a0f8ecb1db3ef15a2cec407c47f8e95bd32851e SHA512 a9c8557d9b4b383a33981d906b19f0f9f8f9bb07aa217b38dfed0e8412356c0afd34671bbd4dd1c9bd3fb7aaf5572a7e284b00d8869f115a41005d5d8ef7c927
MISC metadata.xml 626 BLAKE2B 181917319a1f5bfd6356b2fb06f91892d2432f9ae29a5586c9a6d9579747a676a42d3ee94c1601b53f8ba5c3fc9bbf162b6b3b419ccbc047ead3f1120c2bd056 SHA512 23194fc2a805904809e1df179572fe8e52344b58bda98f064a5221b3637f21f9f8f974e466e65353915b7eb9c66ae23464d1c79e92829147a7c64c6999963f56
diff --git a/dev-python/csvkit/csvkit-1.2.0.ebuild b/dev-python/csvkit/csvkit-1.2.0.ebuild
new file mode 100644
index 000000000000..375b9b2938e6
--- /dev/null
+++ b/dev-python/csvkit/csvkit-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A suite of utilities for converting to and working with CSV"
+HOMEPAGE="
+ https://github.com/wireservice/csvkit/
+ https://pypi.org/project/csvkit/
+"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/agate-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/agate-excel-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/agate-dbf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/agate-sql-0.5.3[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails depending on locale, let's not force en_US
+ tests/test_utilities/test_csvstat.py::TestCSVStat::test_decimal_format
+ )
+ local -x LC_ALL=C.UTF-8
+ epytest
+}