summaryrefslogtreecommitdiff
path: root/dev-python/cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 22:23:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 22:23:02 +0100
commit651f415b41664a0fd7f9e83ac1425ba3670c9518 (patch)
tree6edbaa4a890ab8fdc5dd63ad94f2f0e5d25259b0 /dev-python/cstruct
parent3529f1bf2739399905cd55b27c7609459bfc069f (diff)
gentoo auto-resync : 27:10:2023 - 22:23:02
Diffstat (limited to 'dev-python/cstruct')
-rw-r--r--dev-python/cstruct/Manifest3
-rw-r--r--dev-python/cstruct/cstruct-5.2.ebuild29
-rw-r--r--dev-python/cstruct/metadata.xml15
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/cstruct/Manifest b/dev-python/cstruct/Manifest
new file mode 100644
index 000000000000..a25c0b8ee46e
--- /dev/null
+++ b/dev-python/cstruct/Manifest
@@ -0,0 +1,3 @@
+DIST python-cstruct-5.2.gh.tar.gz 38551 BLAKE2B d366c7508c33f7dd492cb3a507a358129159634b9f32293c4a06a8c1a24e9d4ae5e6a1fd89144907497e17b2558277fe98d4a5d92313402304bb18bec5c395ea SHA512 d9a961270e4769d1133a459f952f22b42733421436c53ac9bfc8159330503af1a2231c99afb2e91863ee8ad4d822a0d84fc6db6aac11b5358bca5548f0006e3e
+EBUILD cstruct-5.2.ebuild 585 BLAKE2B 26f2f70fe8eeccf83c219d3beb6894c0e227f6cfd14bfc9dfde90195c5ffdec3d9d07bf63edfce5d7c4a069b51d82b80dab42f1fe82e1d27230259dce4efdc1d SHA512 4eec68dbcb61820652768ceaf308065502f34f3987e258b06d3c596a917187b1ab80b47e8cdb91c5a36b85e41e8750e7862d47bfb540f0d22f67252f5857ebbd
+MISC metadata.xml 454 BLAKE2B 5138bc275b0b9e18cab52fb309283c6b6dab8be5dcc3c86dd6526f350b216c68bc94dd2aabc7a33a4879c23165924563396c6d5991f5c702a12e184067d25cdb SHA512 bb259a25444029d8ea63577f0576ab283282298d27987e276bf4eb6d4ef00853ed019ad199830e9bb4e738f9a151feb55d53e76917508f1033c2b3ecd246276f
diff --git a/dev-python/cstruct/cstruct-5.2.ebuild b/dev-python/cstruct/cstruct-5.2.ebuild
new file mode 100644
index 000000000000..c5c488dca699
--- /dev/null
+++ b/dev-python/cstruct/cstruct-5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-cstruct-${PV}
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/python-cstruct/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
diff --git a/dev-python/cstruct/metadata.xml b/dev-python/cstruct/metadata.xml
new file mode 100644
index 000000000000..d1468dcb4ec3
--- /dev/null
+++ b/dev-python/cstruct/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">andreax79/python-cstruct</remote-id>
+ <remote-id type="pypi">cstruct</remote-id>
+ </upstream>
+</pkgmetadata>