summaryrefslogtreecommitdiff
path: root/dev-python/croniter/croniter-0.3.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/croniter/croniter-0.3.30.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/croniter/croniter-0.3.30.ebuild')
-rw-r--r--dev-python/croniter/croniter-0.3.30.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/croniter/croniter-0.3.30.ebuild b/dev-python/croniter/croniter-0.3.30.ebuild
index debbc4fd5e47..5d7fc07fd3da 100644
--- a/dev-python/croniter/croniter-0.3.30.ebuild
+++ b/dev-python/croniter/croniter-0.3.30.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -16,7 +18,7 @@ KEYWORDS="amd64 ~arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]