summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 09:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 09:47:15 +0000
commit4241e2d11b148ec5e384070a86c12f7ad7b1884d (patch)
treec3e9f8d9d0e1fe023d4b1f48dc51ac7b09e8c5cd /dev-python/crispy-bootstrap5
parenta4d738a9d1fddef251ba88e258acdb50c243fa63 (diff)
gentoo auto-resync : 31:10:2023 - 09:47:15
Diffstat (limited to 'dev-python/crispy-bootstrap5')
-rw-r--r--dev-python/crispy-bootstrap5/Manifest2
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap5/Manifest b/dev-python/crispy-bootstrap5/Manifest
index 308a3a60d5d2..84a950d28e5c 100644
--- a/dev-python/crispy-bootstrap5/Manifest
+++ b/dev-python/crispy-bootstrap5/Manifest
@@ -1,4 +1,6 @@
AUX crispy-bootstrap5-0.7-test.patch 6530 BLAKE2B a8a987e0a32ff4976575def65e9fdd893d7b28af9d1793de62daf6e9823023275b3a0735f037d23e82d6c0fb9143cdd6fb6d2d7787aab607c8dc0075268e8f7a SHA512 b185c09df4428f729d0f9afbbe22ba33edae059083cf28eb164e85ba971e700b112eb3bbf71952ee659302b62452de0a7ac2c0aee7e21908d55cab0d50d6d3ec
DIST crispy-bootstrap5-0.7.gh.tar.gz 29728 BLAKE2B 1209ab7d8340e30c71050ed60a86d8233f454c49d2f6d4fcf4f1d6be4a7d1c470c3f907211c1ee352fc3eba9a74e8152d41162e4d6f8113538eccbb3522409a5 SHA512 c73305c6661719cd45989679c33751f44b318b39f895e0328257eaffcdd52b726be9be624ebecb6bcba35635f0f615bb83e48c775e0f05c40f8f1e6e80ab737c
+DIST crispy-bootstrap5-2023.10.gh.tar.gz 31222 BLAKE2B cab972ed222ba0245d0a0d6e75487aac03c054f8669859fc4eb8293c2abb3775ef76f6866402917d1d1bfa0444548983639a24bd5fd4d1c2a3bbd74d1c086057 SHA512 379e4ea536809ceeb347d8894953acd97362c7340cb496727e4f56c2967aba93b1b041166ba6b8253d4952e4fa97f80668041733ddbd2ca62b60f4f9046259ef
EBUILD crispy-bootstrap5-0.7.ebuild 743 BLAKE2B 651eaeccc6a64faa98676b2badf91fdd00c7f1451293aec1f1fbcad8f3cce077efff9cc931ad39246ced64eb063e87d98702eea1adf7997bf9524edd970f7f22 SHA512 e8630213fd6cd1d265d78c2c03d03a5b77614b9935b8b49c7676f4d02a9fdca687bf5dcebe382930649e7a9b44dd81e34f9d979a2645104fdf05e19a21bb1b78
+EBUILD crispy-bootstrap5-2023.10.ebuild 746 BLAKE2B 8d9449f426d77d037b95e1855802bea380ba3b8c044723c4d0e5a8299521cce5ff5527388d36596f840a46cfe313cb896fba3779b28ace7e7597df760b198bce SHA512 9a83cef4fcb829adbd7cd671c2ecd7341559bb0c5b1a7314d2e0f0630fda3036f12689b7c6dab48f413dade941bfe96994a880a0d192f767f72e31ff2bd75e2f
MISC metadata.xml 405 BLAKE2B 4b4a3bf239037510067beb822fe736db7235f0f530504831e7e64b70b311f34d52e842b19b155ba3bad6d607b25cbda34d926bd6691da2316551f3d86b11c94e SHA512 4c44e8ae1e2729af4c84217f287316e1aa098b80c62770d77cf690bc8c34f6df03f0aed2ef4c5ef22e423270abf737058f48f64b78d7b2b882b151992b0701a8
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild
new file mode 100644
index 000000000000..b21a1f0b456f
--- /dev/null
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2023.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
+ https://pypi.org/project/crispy-bootstrap5/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest