summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
commit5a2a5572ac35843b9cd1c9369bd96e117647d24f (patch)
tree4f3b96f8834f6c6a9742a7a7e9f3453240fc5cbe /dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
parent01f09076452fe45dac176dc2c4fff1ba81f3b5e0 (diff)
gentoo auto-resync : 16:10:2023 - 09:55:38
Diffstat (limited to 'dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild')
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
index a1e440cc9f5b..b04b976d40a0 100644
--- a/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-0.7.ebuild
@@ -4,26 +4,35 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
+
inherit distutils-r1
DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
https://pypi.org/project/crispy-bootstrap5/
"
-SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RDEPEND="dev-python/django-crispy-forms[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pytest-django[${PYTHON_USEDEP}]
-)"
+RDEPEND="
+ dev-python/django-crispy-forms[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+)