summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-06 04:27:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-06 04:27:04 +0100
commitd6106fb0c1ab8f79024ab6a9ac2062ddc85d4e07 (patch)
treef3a4ad4dcf443e9351fa5dec88afeeec86c9b642 /dev-python/crispy-bootstrap4
parentf3f72d0d5f1ae9ee74acaa63ccb7a247468e73bf (diff)
gentoo auto-resync : 06:10:2024 - 04:27:04
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest2
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.10.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
index d3a4fb0fe44d..1dcdd76a5357 100644
--- a/dev-python/crispy-bootstrap4/Manifest
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -1,3 +1,5 @@
DIST crispy-bootstrap4-2024.1.gh.tar.gz 31818 BLAKE2B 5778544067c7c23971a410bb52556a267fed9109bee4b5a4cd7e72c9bde0888e6744c2e12aa079c92217c0b6bc0ef2709de2eae127fe92ccc92ca1acb5015aa6 SHA512 c4c4e02117a2b3cf24c9111579c20f1454c5feb8c485c954e48436354e82d0a26e34b54212fb642d010a7c370236028119e5193fdb43ff2053cabae56a01a7c2
+DIST crispy-bootstrap4-2024.10.gh.tar.gz 32278 BLAKE2B 8104bc4964fa11df05a6b6e244e4c58cc678225afdedf4a72749cc74986d8b763c6fe32aba9376d2a4077ac765c06df4582fa796caee885e82156c81369dcf16 SHA512 4cd7cde7d987baa5f6806076fe7f991e450544427deee9b0e64a45acd94b2987352369a6d277b90e6c9ff19e35225a3b5bc219336725b67e4aa0c8280cd6ac12
EBUILD crispy-bootstrap4-2024.1.ebuild 753 BLAKE2B 600db51acac4b86c9cb6e822f9cf499d50ae7cf43a2d061438badd2c6ac3d398dabab05c4db35ff7c05e43ebb2896ec65cc319ad1b618e7f5e434a983f6127b5 SHA512 96a5e78b47bf6c05853d6630d35c88316844632863ebc9c1957de809ee4fc101366b2d70d123c1637ec7e2ef9a100ba66d1c6ee2bf2f357a4e6997288ad5dafc
+EBUILD crispy-bootstrap4-2024.10.ebuild 753 BLAKE2B 600db51acac4b86c9cb6e822f9cf499d50ae7cf43a2d061438badd2c6ac3d398dabab05c4db35ff7c05e43ebb2896ec65cc319ad1b618e7f5e434a983f6127b5 SHA512 96a5e78b47bf6c05853d6630d35c88316844632863ebc9c1957de809ee4fc101366b2d70d123c1637ec7e2ef9a100ba66d1c6ee2bf2f357a4e6997288ad5dafc
MISC metadata.xml 405 BLAKE2B ec5d0537b699db8dd80bde37a759e754e8bc9c96c514cc8e24b43534c68dfcc44e44e219eec4912d8bd42184c92b866c19eb68da24e4ef780f821a2d855c3c79 SHA512 0398280620b4f7fe239e3ded58d04a14ae7a7c3b6597c496277d923d52ae7ce3600c0509e1c9a8187aeb0f2c012a4f7088308fe15eef6649406c09e893b66da0
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.10.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.10.ebuild
new file mode 100644
index 000000000000..a566d2401f56
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/
+ https://pypi.org/project/crispy-bootstrap4/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest