summaryrefslogtreecommitdiff
path: root/dev-python/crispy-bootstrap4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 05:40:38 +0000
commit88f366f99d8e731ae1a13d9eca9a5284484d2c6f (patch)
tree07a82726de0e87969c85cdfb68522c4d444939e9 /dev-python/crispy-bootstrap4
parentfdd31f37b982d2c1b6d73b85f99718b13031be36 (diff)
gentoo auto-resync : 28:02:2024 - 05:40:38
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest2
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
index 85d05be98ed4..a601186e50be 100644
--- a/dev-python/crispy-bootstrap4/Manifest
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -1,3 +1,5 @@
DIST crispy-bootstrap4-2023.1.gh.tar.gz 31707 BLAKE2B 0a3c4c1b86ba9701365f1fcfb90811e1f6793fb9f374a510410c460bc62a48e06b72a75330f0efd3a06e51380f457eea66f236488774c3ee6bf758510136f08b SHA512 fbbc8c6e0f4351b50b0fa3a4d2faefb0775906c995f42cf9ccd9688d4780e05877a9a53f065ad92785d135a560064809f429dbcebe9f257f65f063d9539973e8
+DIST crispy-bootstrap4-2024.1.gh.tar.gz 31818 BLAKE2B 5778544067c7c23971a410bb52556a267fed9109bee4b5a4cd7e72c9bde0888e6744c2e12aa079c92217c0b6bc0ef2709de2eae127fe92ccc92ca1acb5015aa6 SHA512 c4c4e02117a2b3cf24c9111579c20f1454c5feb8c485c954e48436354e82d0a26e34b54212fb642d010a7c370236028119e5193fdb43ff2053cabae56a01a7c2
EBUILD crispy-bootstrap4-2023.1.ebuild 748 BLAKE2B a8c737bbef1986ff8b5f981fab186f1b7b8d319baa00acd642d70ae8c94c76de9c2d9954062702e2347733a1a1a9292a0f047b5d6666b37d259afcf5251962a7 SHA512 0da074f191b5860acc1fac58f5a97ca425b809f3e5c8a600ffd81a1400de18a504f512e0e45898a2542906c4a9124ec9fa51ee9403e92e21fb460d8630882fae
+EBUILD crispy-bootstrap4-2024.1.ebuild 753 BLAKE2B 96080be5291d6fdfa79595ceb1658856681cc9412b0f389aeb2f92646bbfcebb1febff1c809276082ff9630f916ec6c79d85bcfe4d8dbf52704ae3ba30b063e2 SHA512 eeebbb3ee023ec8fe5bf99a8f7b42053cc93cbcf79fbb79c8b7c6511f165feee4e3020f12ae88d35ed8d136a51bfae5f045c1a75e60269ff8d59673128b3074b
MISC metadata.xml 405 BLAKE2B ec5d0537b699db8dd80bde37a759e754e8bc9c96c514cc8e24b43534c68dfcc44e44e219eec4912d8bd42184c92b866c19eb68da24e4ef780f821a2d855c3c79 SHA512 0398280620b4f7fe239e3ded58d04a14ae7a7c3b6597c496277d923d52ae7ce3600c0509e1c9a8187aeb0f2c012a4f7088308fe15eef6649406c09e893b66da0
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild
new file mode 100644
index 000000000000..4f779d097fda
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2024.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/
+ https://pypi.org/project/crispy-bootstrap4/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest