summaryrefslogtreecommitdiff
path: root/dev-python/crcmod/crcmod-1.7-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/crcmod/crcmod-1.7-r5.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/crcmod/crcmod-1.7-r5.ebuild')
-rw-r--r--dev-python/crcmod/crcmod-1.7-r5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/crcmod/crcmod-1.7-r5.ebuild b/dev-python/crcmod/crcmod-1.7-r5.ebuild
new file mode 100644
index 000000000000..0dbac02cd773
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( changelog test/examples.py )
+
+python_test() {
+ "${EPYTHON}" test/test_crcmod.py -v || die "Tests fail with ${EPYTHON}"
+}