summaryrefslogtreecommitdiff
path: root/dev-python/cov-core/cov-core-1.15.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/cov-core/cov-core-1.15.0-r2.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/cov-core/cov-core-1.15.0-r2.ebuild')
-rw-r--r--dev-python/cov-core/cov-core-1.15.0-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cov-core/cov-core-1.15.0-r2.ebuild b/dev-python/cov-core/cov-core-1.15.0-r2.ebuild
new file mode 100644
index 000000000000..83c5764ec713
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://github.com/schlamar/cov-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"