summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-python/contourpy
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.1.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index b1e2c26262b0..ca8e360d0d1b 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,3 +1,5 @@
DIST contourpy-1.0.7.gh.tar.gz 13357940 BLAKE2B 740214d68eb95c2d80dfb4008fbf82ae1bbd7135476a7f1a45863e2fd88331c959e80dd56afde67789e95325fe4613a6404c24d4deafebacfabbdebc0b199dfe SHA512 64edcfc911b3d7af9b422058d1f595c05d64f7fca8511ea199d30fa52854aee53a7c7dd95e2f47964f57e7764ce6b7b05c8ccee5ed0309eb5daa822d488ce0ff
+DIST contourpy-1.1.0.gh.tar.gz 13413711 BLAKE2B 020bf7f63dbe304e71b66249cdfa86047598a3f8352657f7c179bc068869bf7659fb7c821749a0be33a8a04ec02dc642ac7a9ed14f5fd73d4a1e9f20c3606ee2 SHA512 aeb60db039aa14aed29a31dcf6091708daf7e65589964dd7682dc28e085d584103abb872e607685408eaefd4947adeba966c9a0d93cb1f827805189e498c67d8
EBUILD contourpy-1.0.7.ebuild 1096 BLAKE2B c3317bcfe470279d63620caecf219d03b281ad4a7c194bb3ed701324f9fa3cdc0bb61b9fadd59334af923ad97f9146317a271c15b885897ef0344de5b8a51486 SHA512 f6e416ba0d6382842484d1f88183d5f50b49663c9b1f7157359973b8dcc7b25e7912b3c793f68671a6e52390f5168ef37c95af40621b114ec91803023f94da2a
+EBUILD contourpy-1.1.0.ebuild 958 BLAKE2B 61e31cef6094af272b0010dabf476ed711fa433b55f80f8febe887e7b54bea48115b088c960a37b2be938b629688b7ec78519d68c441cf0ca5430a688c8f0847 SHA512 9366f1990218e7d46ebd699f6f599afc4d1f6c75e4426727d9c045216f8128a983a24738abbc4ab3d4f5e98fdfa10355ad4b859a711ddcc13b87fd8c1fa4610c
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.1.0.ebuild b/dev-python/contourpy/contourpy-1.1.0.ebuild
new file mode 100644
index 000000000000..b62d02738e9e
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wurlitzer[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}