summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 23:08:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 23:08:59 +0000
commita29a0019eaf0bf87941bdc1d9cd53937685852ee (patch)
tree64c0a3ecbbede7a93bb6625c84b70668941be13a /dev-python/contourpy
parent5a31d854eec302fd1efb1466af757e520ae4e1dc (diff)
gentoo auto-resync : 19:11:2023 - 23:08:59
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.2.0.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index b7e7fa685794..f6309f24360e 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -2,5 +2,5 @@ AUX contourpy-1.2.0-unicore.patch 3169 BLAKE2B 436bd8b179be7bb695694de4254be53fc
DIST contourpy-1.1.1.gh.tar.gz 13417093 BLAKE2B 217b99a1000575d362ca60327f39d39fd5f241f1e0f94ac3f049e2bf195388424f10bfd33c2a007da32eb939c1a04e96942ce0092c091533166c54da906b68af SHA512 7d135f18fa28ecd5d6c715650fc5672291c6f46e96cfcf8d2571c401d5bae0d27fa6a2e9f80e4f735af3016c7ced92552f26e8c5519e725e1bf6fe54c7603a03
DIST contourpy-1.2.0.gh.tar.gz 13440145 BLAKE2B c8082f69c3c8ad2b9a2d7a8e68941f1b741b0527161df371b501a32b8f0572a012aa2184b9f3ea943f45143f218f910180e31371683826d2b9b9431537c72cbd SHA512 91084ca659f796fb49f34840fb08a1a8f2a78ce8264668f5729550b1c46f316933c1d76ed87797bf58a059f0cf63e6efc58c92e44c57787fc8ad1ca16a21aa6e
EBUILD contourpy-1.1.1.ebuild 1060 BLAKE2B 47d65894caf62c757a248827c707ce4c5542fd650d49c94bbe70bd2f0f0b0befcb67c4673bb0b29f5364a19975bd9e5ab6d2ed7f0630c4fadd4ed82bcc81cb3a SHA512 88032aaa6f108f938fdd4b10aca5caef5a214fd1a041cffc973b46dd37ec5cf3a3e3d6fd7351b4165a48989b2aad5e7b3f4db19b3ec829b39d4a9d3ab60a8419
-EBUILD contourpy-1.2.0.ebuild 1274 BLAKE2B e1ccdd5c2f605e7cc4c67c499a3b52f5a6f0646f68d0dc074ee939fd4c6442b33878d4ac6a5089efadbff8a5ac7a2e9bd3b1aaa662b338f8f8c89c6da48a127a SHA512 1f3015f9618e114280a891a925a805901f6f4dfcd825914f59c214faf9f71eba167c5552ceb238c4f1ee12d1d462d0ebeb6ee62b0ad19c2663051815d9289fc6
+EBUILD contourpy-1.2.0.ebuild 1188 BLAKE2B 2cfa6580a6e1fc9bd4439787f4540198564f6e912fc95f24285de2d65226ece6a058e793c99a5560d6d20b1d87647499ac4ccc36cad68c91397babd8a256244a SHA512 90acdc5e4a30a58febb05e00300ec067f49e0b98fe447d24479daaace69f010b82d3e12aa255b80a0cbeb7f09134e9caafd2c5e3cf594789a998de1ac19cd215
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.2.0.ebuild b/dev-python/contourpy/contourpy-1.2.0.ebuild
index 22e5a6586da3..826fa84ae3f5 100644
--- a/dev-python/contourpy/contourpy-1.2.0.ebuild
+++ b/dev-python/contourpy/contourpy-1.2.0.ebuild
@@ -5,9 +5,9 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1 multiprocessing
+inherit distutils-r1
DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
HOMEPAGE="
@@ -31,7 +31,6 @@ BDEPEND="
test? (
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/wurlitzer[${PYTHON_USEDEP}]
)
"
@@ -40,6 +39,7 @@ DISTUTILS_ARGS=(
-Dwerror=false
)
+EPYTEST_XDIST=1
distutils_enable_tests pytest
PATCHES=(
@@ -53,5 +53,5 @@ python_test() {
tests/test_codebase.py
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+ epytest
}