summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /dev-python/contourpy
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.1.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 7885b1880363..c6d7c17afc7b 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,3 +1,5 @@
DIST contourpy-1.1.0.gh.tar.gz 13413711 BLAKE2B 020bf7f63dbe304e71b66249cdfa86047598a3f8352657f7c179bc068869bf7659fb7c821749a0be33a8a04ec02dc642ac7a9ed14f5fd73d4a1e9f20c3606ee2 SHA512 aeb60db039aa14aed29a31dcf6091708daf7e65589964dd7682dc28e085d584103abb872e607685408eaefd4947adeba966c9a0d93cb1f827805189e498c67d8
+DIST contourpy-1.1.1.gh.tar.gz 13417093 BLAKE2B 217b99a1000575d362ca60327f39d39fd5f241f1e0f94ac3f049e2bf195388424f10bfd33c2a007da32eb939c1a04e96942ce0092c091533166c54da906b68af SHA512 7d135f18fa28ecd5d6c715650fc5672291c6f46e96cfcf8d2571c401d5bae0d27fa6a2e9f80e4f735af3016c7ced92552f26e8c5519e725e1bf6fe54c7603a03
EBUILD contourpy-1.1.0.ebuild 1024 BLAKE2B 3cd165023b3eea552cc48bcb75029a5845c5d0093ce973eb29c263e89007d139e86753bc271c5862be043438f831e8c8d479481217ffb9b04fdae80153a7e3a5 SHA512 45ca7414f8f6f9b31f97a938dee3611520cde61c6d6905ecb62e38a42d5817692089b1463e88178a7f5a19e382cfca62ff31259b280bc1da30662b62623bb3e2
+EBUILD contourpy-1.1.1.ebuild 1032 BLAKE2B 5c697b8e3ea218432d57b588b6684241101c0130b74d47dba0beec8708c7c3d9e5ca2adfe7c19172cc4cf4a3f8b2ff09a33c6e5b7c6ba68a21cb2aacdab0a0c2 SHA512 3ef407c47dae128ad81ec0b4e06371f1b42622fd3f60bb0b2a5bcf614a1f892d99d50278c2e6880838be4dab1234bc30111f4b6f6a2be3412504bd14772a6aeb
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.1.1.ebuild b/dev-python/contourpy/contourpy-1.1.1.ebuild
new file mode 100644
index 000000000000..35481e118590
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wurlitzer[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}