summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 05:50:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 05:50:43 +0000
commit3a60b38f14fa81df8e18aa67d1634fbffca17d14 (patch)
tree2db4eb443cdf196f01a18d0c053ff46d6bd5626d /dev-python/contourpy
parentea8740cede74808fe1546789e18738612217bb97 (diff)
gentoo auto-resync : 14:01:2023 - 05:50:42
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.0.7.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 225713ad5825..cd23afe69bcb 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,3 +1,5 @@
DIST contourpy-1.0.6.gh.tar.gz 12154065 BLAKE2B d0a621e10bc465a0ed4a20136e813435bb4d79bdd39b64d60676bb794430f2ce15b247e13e163e8e2f89c69ea6a5880dc8f3c8a49750c15e7bcb554aeefcbac1 SHA512 3b6301b414758d588015b745be723642554459df14277aa2eb2def7b5194e0a2b73b73ce8409bc40cda34095e13984d7a2dbc1f3a1dcf272766df92d1de1b5ef
+DIST contourpy-1.0.7.gh.tar.gz 13357940 BLAKE2B 740214d68eb95c2d80dfb4008fbf82ae1bbd7135476a7f1a45863e2fd88331c959e80dd56afde67789e95325fe4613a6404c24d4deafebacfabbdebc0b199dfe SHA512 64edcfc911b3d7af9b422058d1f595c05d64f7fca8511ea199d30fa52854aee53a7c7dd95e2f47964f57e7764ce6b7b05c8ccee5ed0309eb5daa822d488ce0ff
EBUILD contourpy-1.0.6.ebuild 1082 BLAKE2B a8288899e207bbcf2c61ff06575aff5f3112e0c4d516098a1ff5453ed612a2c5a50307020e25ebdac08fcef1ccc947ec874ad7c06f57aafd611daeea2aa5fce5 SHA512 962c3a92296f1504fc9cc700db9ebe15fbaf1e7eefb7da51a5f0e213296c0da3fc1ea1418f0d6b401ffc697cbf5a93e6cec9b2f0611ba72c4af365b4d924f0f5
+EBUILD contourpy-1.0.7.ebuild 1088 BLAKE2B d2f74603bacdfa0fc3c7fceb6814bd82c6b560b264c4c1b6b554a22c57a5b0ca2de32ea0968ed754696a74dc8ba6e2940ccd3141809117581e5ed12f64c1e11c SHA512 acef68fc1fa970fa8f3d9ceb8f3fc1962b98f36e0404297418174943dbe00c0cc328012875cde139e3ba4d6897d982172e76f472188b1d80bf11e640af2f4e3e
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.0.7.ebuild b/dev-python/contourpy/contourpy-1.0.7.ebuild
new file mode 100644
index 000000000000..2472a410a2d5
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.0.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # threaded algorithms are known to be broken
+ # https://github.com/contourpy/contourpy/issues/163
+ epytest -k "not threaded and not threads"
+}