summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
commit171d09fa1f429aa43835c618a2c21753ad5209a4 (patch)
tree7a9f3e0ed5e5a7dbabf98c971e8202b7ce50035b /dev-python/contourpy
parent1826a30af36ae674cb71400eacaf0a0762df510f (diff)
gentoo auto-resync : 21:02:2023 - 14:24:25
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest2
-rw-r--r--dev-python/contourpy/contourpy-1.0.6.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 49ddb750cc43..2b0f5f843dfe 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,5 +1,3 @@
-DIST contourpy-1.0.6.gh.tar.gz 12154065 BLAKE2B d0a621e10bc465a0ed4a20136e813435bb4d79bdd39b64d60676bb794430f2ce15b247e13e163e8e2f89c69ea6a5880dc8f3c8a49750c15e7bcb554aeefcbac1 SHA512 3b6301b414758d588015b745be723642554459df14277aa2eb2def7b5194e0a2b73b73ce8409bc40cda34095e13984d7a2dbc1f3a1dcf272766df92d1de1b5ef
DIST contourpy-1.0.7.gh.tar.gz 13357940 BLAKE2B 740214d68eb95c2d80dfb4008fbf82ae1bbd7135476a7f1a45863e2fd88331c959e80dd56afde67789e95325fe4613a6404c24d4deafebacfabbdebc0b199dfe SHA512 64edcfc911b3d7af9b422058d1f595c05d64f7fca8511ea199d30fa52854aee53a7c7dd95e2f47964f57e7764ce6b7b05c8ccee5ed0309eb5daa822d488ce0ff
-EBUILD contourpy-1.0.6.ebuild 1087 BLAKE2B bcb39aa80fe45654388e4561579b655b63f0dd4503e4f36fd9c031c60b7d2acea6c8915bfc909aef82bbeeb58dcd1549b7ec015321b619e062b8fb0188f958a2 SHA512 422413fc7f7892421a6be4fcb1d52cf3ca9d448dc5376ff4ec9222093600f2ffe3d2b660c596f578bd8b4dc150e9c9bf4592e525d65fc0febf2399783a9e3acc
EBUILD contourpy-1.0.7.ebuild 1087 BLAKE2B bcb39aa80fe45654388e4561579b655b63f0dd4503e4f36fd9c031c60b7d2acea6c8915bfc909aef82bbeeb58dcd1549b7ec015321b619e062b8fb0188f958a2 SHA512 422413fc7f7892421a6be4fcb1d52cf3ca9d448dc5376ff4ec9222093600f2ffe3d2b660c596f578bd8b4dc150e9c9bf4592e525d65fc0febf2399783a9e3acc
MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.0.6.ebuild b/dev-python/contourpy/contourpy-1.0.6.ebuild
deleted file mode 100644
index f05ea26574ed..000000000000
--- a/dev-python/contourpy/contourpy-1.0.6.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # threaded algorithms are known to be broken
- # https://github.com/contourpy/contourpy/issues/163
- epytest -k "not threaded and not threads"
-}