summaryrefslogtreecommitdiff
path: root/dev-python/contourpy/contourpy-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-11 09:29:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-11 09:29:30 +0000
commit7d6f532c36268a2a8f53fa33c8e547c59702faa6 (patch)
tree6fd7a5cb102e736fe8969482dbce6c8a98808f6f /dev-python/contourpy/contourpy-1.0.5.ebuild
parentb4899ed9fc78f45325ef4e2ebd460869e53a605d (diff)
gentoo auto-resync : 11:11:2022 - 09:29:30
Diffstat (limited to 'dev-python/contourpy/contourpy-1.0.5.ebuild')
-rw-r--r--dev-python/contourpy/contourpy-1.0.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/contourpy/contourpy-1.0.5.ebuild b/dev-python/contourpy/contourpy-1.0.5.ebuild
deleted file mode 100644
index 972f9f2d56d9..000000000000
--- a/dev-python/contourpy/contourpy-1.0.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # threaded algorithms are known to be broken
- # https://github.com/contourpy/contourpy/issues/163
- epytest -k "not threaded and not threads"
-}