summaryrefslogtreecommitdiff
path: root/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild')
-rw-r--r--dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild b/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
new file mode 100644
index 000000000000..201b3c103c79
--- /dev/null
+++ b/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${PN}-${PV/_p/.post}"
+DESCRIPTION="Backports and enhancements for the contextlib module"
+HOMEPAGE="https://pypi.org/project/contextlib2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
+IUSE="test"
+
+DEPEND="
+ test? ( $(python_gen_cond_dep '
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ ' python2_7 pypy3
+ )
+ )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+RESTRICT="!test? ( test )"
+
+DOCS=( NEWS.rst README.rst )
+
+python_prepare_all() {
+ sed -i -e 's:unittest.main():unittest.main(verbosity=2):' \
+ test_contextlib2.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test_contextlib2.py || die "Tests fail for ${EPYTHON}"
+}