summaryrefslogtreecommitdiff
path: root/dev-python/construct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/construct
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest2
-rw-r--r--dev-python/construct/construct-2.10.68.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 2333fe5481b2..d54038b104cb 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,3 +1,5 @@
DIST construct-2.10.67.tar.gz 1189939 BLAKE2B e3effd2bb2906435208ef6a5fadbdbde2e1ef3565174568949207bdace48e25f423932f08598c82df661919d926a18d49767ea1189b01a5a3ee48aae601c45c8 SHA512 a4c7cc32b9eb63311c6ae2b1580b7a696c1e0c3960d78936798dd794cb37a77ec8ed8baa8128f12abd50390b9f4cb3f150e3453d5043797f0bd603525b8292a5
+DIST construct-2.10.68.tar.gz 1190512 BLAKE2B b41e5b3b62cd1568c78ac4975b0d66e7a7ad4489e97031d3e866ff8eb98eea4eb387041dce15210304c608e0c419548cddea3557c2f53d52ecbcf6eb5be67749 SHA512 2388751323b16b69a06457c4862e7d1334580c201050734f150ab4437e2066ed18ff5323f7d81b8bb93124ae0f57a2ae91d7c64ffefc6e0369d6e625b7fef4eb
EBUILD construct-2.10.67.ebuild 1014 BLAKE2B 6b444e2fcff9e54ee78e9006e91c061336ed79db45c7577bfc072213c09b3fc96815b7719ebd552966bc3b479eacb37b4fc90ad0e7f81efa2a498306d0fff5c2 SHA512 02ccda08e22eff4b51219c415ae23caa870f584e83be50feae405abe934580b81c28c68983496050a1a4f489286d0136695f92b0fb0a3ee20c94a99f7c12c0de
+EBUILD construct-2.10.68.ebuild 1050 BLAKE2B 113909e13c385f5af7ec1e328b5b7ca156820c570fec7fa3dfbae6b7f30807a0b278d20d3c40d1cdc95ee962397e8dbe8629decd13027115976cc3a4069b0bdb SHA512 23075643b6ff3084b496167e3e74a8d71c354b1979bcbe8343d85fc29ab91fa470bdf4d75cdf1e475da735602043fd73a330fe3c45b7c62d0de3143bccf0efe6
MISC metadata.xml 530 BLAKE2B 841ba440080eb109449759509abcefb1449a87e3aed1f63a2acf021e6bb8c18e67d4e7e6c85d530877b7a2eb3de167708a728ad35507e3e6268f2d3f202018a1 SHA512 6c0e4d31dfaf335a7f94bc21866791100f8e96f5d58aaf988a48c55a054f5ac5d7ef579943a01d68e1403432b33f62c241b2a06dcf874278a1424f3cf60c8caf
diff --git a/dev-python/construct/construct-2.10.68.ebuild b/dev-python/construct/construct-2.10.68.ebuild
new file mode 100644
index 000000000000..b97a308445b2
--- /dev/null
+++ b/dev-python/construct/construct-2.10.68.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="https://construct.readthedocs.io/en/latest/ https://pypi.org/project/construct/"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}