summaryrefslogtreecommitdiff
path: root/dev-python/construct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /dev-python/construct
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'dev-python/construct')
-rw-r--r--dev-python/construct/Manifest2
-rw-r--r--dev-python/construct/construct-2.8.21.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 00332c3e1adf..4b3fb7aa1aef 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,3 +1,5 @@
DIST construct-2.8.17.tar.gz 705812 BLAKE2B 3178f7f59fb893bc521c88b7ba51d6bd83cca37c1a243e602dcc2ac41a2cb7335e2cf69e7dff3b130e974ff9dbd01a12004423c3a88fc8e88c784c665437e901 SHA512 5bca40d7f33f336ab2a66546027c8bf24bf1b0125bcf425063b3bab14b1e3a96577d602db1eb73cb0ee99f90d92af6e24fcbd228912c0a70de6b2bd7d33e75be
+DIST construct-2.8.21.tar.gz 706022 BLAKE2B a7fb81185b380b444bede5dffce11158d93f0076cc3fbd836cdef3cf8425e2bcce0cf7b8e2d2654effc8beac3d3d0f722dd2786103f9b85f05b98216fc7684cb SHA512 f8e2c8d0f437cce760b1439fc68e2b10dccf852e1bf3c42e0569a3e32fe218d2a4d4cc662229455a910fa8a7cf0fc0500cb0d38ad0485f1b9fd954334f343562
EBUILD construct-2.8.17.ebuild 708 BLAKE2B 1c67690079a5c288769c30c8717d0ba83c8df1e22fbfd84d81427364fc8c7c19947d6d231cb90b08a1137f16ea26f2df126872e83be210cb4893e33d4f90e4b5 SHA512 74633e9f4beb1abd73ea78de7e6ea6821f0ca0d0d0e429d9b90105aae5bddec5f7452a15e48824e16a2cfefc379d3a0db26b163a84a722367583d61ccb6f758d
+EBUILD construct-2.8.21.ebuild 712 BLAKE2B 2ec3795f5ae5e9e2afd3f553ed52a8d633dec54db08cc51248db47f8e73235ce7f126499ca590c8da4b6526068909da589fe86971f360742ea0a7abf62a47795 SHA512 04c172e06943f59b2a25365475605ab55f37e930f24f2bc199614ba1bd1e7dd9e4a40b19b99e4d1c49ba3c5288ac760200111b219c725daa9752e7803313e120
MISC metadata.xml 491 BLAKE2B bf8f7729988a0a4c39c9f8081a4b05560d1596a69c8670e378ea1f1f81b8dd5a2c366e8211c36e07f809378c6ae769b01181a4ceaf3f82ec8eb2b1879d874a87 SHA512 a8a85937bda8fb36a51bd6e0c0bcb1ce721073ee07a8e198c88b64ee484e8fd1c813e937443885e5ea2e532cda3971e8eb59385797a7a8f44ec9524a57acbbf9
diff --git a/dev-python/construct/construct-2.8.21.ebuild b/dev-python/construct/construct-2.8.21.ebuild
new file mode 100644
index 000000000000..70ec0fd0fff1
--- /dev/null
+++ b/dev-python/construct/construct-2.8.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}