summaryrefslogtreecommitdiff
path: root/dev-python/constantly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
commit14bda3c9c57c13e8a59303f400678313fd770bdd (patch)
tree1d76323e4e249e0515128cd6ca42e167a9575294 /dev-python/constantly
parente5346f2f512bd7faf413f3de3ef7fbcfbcd974b3 (diff)
gentoo auto-resync : 28:05:2023 - 21:15:34
Diffstat (limited to 'dev-python/constantly')
-rw-r--r--dev-python/constantly/Manifest1
-rw-r--r--dev-python/constantly/constantly-15.1.0-r3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/constantly/Manifest b/dev-python/constantly/Manifest
index 173740e97843..1b342cb69fa1 100644
--- a/dev-python/constantly/Manifest
+++ b/dev-python/constantly/Manifest
@@ -1,3 +1,4 @@
DIST constantly-15.1.0.gh.tar.gz 40635 BLAKE2B d400336901f7df7b1535a0e46fe092a2542546964ea144014210e8be3807aabfe8e8370e94f426061a0c3a6257ee66a6ceb963b159717def7e047405368d910e SHA512 eeaa74552fe8e01c40566ac3c8b3d41085f800863ac516e30fe1242f40d3401e4e872279149776f29d3ba78a7a16337a794ad26230efab4dd1847d42bffa81ce
EBUILD constantly-15.1.0-r2.ebuild 713 BLAKE2B e8d56bd90dd6227824fdce22ca96b3bd4a25f4212b3fbdcf9e3eb0dd42019b66a8fb6c7615bef7845df09c731d18632a85246d7235141219c6847db380615eac SHA512 407464c96dcc735702238362a58b924e76756307bd2cd015b30d3535a86983143dea52dd294c18176ee514517c545be3c0ab5533e02a9257c237915d377c16dc
+EBUILD constantly-15.1.0-r3.ebuild 890 BLAKE2B fe5fcfdd61de7f45dd1056f50aacf7c19b5b982a442fcb5779fd407715f8494025619f36dc47c05005777466ab0c778d043e3854b80db817d968ce63912798d6 SHA512 7ca6392269f027b9cac327ef46216e9b34fe25dca16483999a05c176f24e7fe702f91b60254a06b9381a1ecaa837669615c7257ef3ef71aa83bba4eed6c55949
MISC metadata.xml 762 BLAKE2B 9875a3eb5843bf6bf12053dec018f6613df587a09c15e789c8386fda56b9f992cecff183961d2ad6666c222897953afca84b3c16cea971ea51d59d85dd977d4a SHA512 2da01cbce721e0f9b411e6d34552bbe547d79dcf3c2bc0232b8addfcfc98a190eff1fef7ae09e451e4666a7854c83206cc5b905aa951b7ce9476124fc6f0023c
diff --git a/dev-python/constantly/constantly-15.1.0-r3.ebuild b/dev-python/constantly/constantly-15.1.0-r3.ebuild
new file mode 100644
index 000000000000..9246a503bf34
--- /dev/null
+++ b/dev-python/constantly/constantly-15.1.0-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Symbolic constants in Python"
+HOMEPAGE="https://github.com/twisted/constantly https://pypi.org/project/constantly/"
+SRC_URI="https://github.com/twisted/constantly/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # https://github.com/twisted/constantly/pull/27
+ rm versioneer.py || die
+
+ distutils-r1_python_prepare_all
+}