summaryrefslogtreecommitdiff
path: root/dev-python/confuse/confuse-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
commit9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (patch)
tree4ac39398cd519351bf12c6357e7474c508f19d13 /dev-python/confuse/confuse-2.0.0.ebuild
parentb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (diff)
gentoo auto-resync : 17:07:2022 - 14:31:38
Diffstat (limited to 'dev-python/confuse/confuse-2.0.0.ebuild')
-rw-r--r--dev-python/confuse/confuse-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/confuse/confuse-2.0.0.ebuild b/dev-python/confuse/confuse-2.0.0.ebuild
new file mode 100644
index 000000000000..2a48b8b1241c
--- /dev/null
+++ b/dev-python/confuse/confuse-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="
+ https://github.com/beetbox/confuse/
+ https://pypi.org/project/confuse/
+"
+SRC_URI="
+ https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'