summaryrefslogtreecommitdiff
path: root/dev-python/confusable-homoglyphs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
commit28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (patch)
tree6d6b6b0a1aca19e8118845870c9e6a25bad27963 /dev-python/confusable-homoglyphs
parent840a65e2af3f2cc7527e723a28f6e627a9592fb7 (diff)
gentoo auto-resync : 30:01:2024 - 17:49:05
Diffstat (limited to 'dev-python/confusable-homoglyphs')
-rw-r--r--dev-python/confusable-homoglyphs/Manifest5
-rw-r--r--dev-python/confusable-homoglyphs/confusable-homoglyphs-3.2.0-r2.ebuild34
-rw-r--r--dev-python/confusable-homoglyphs/confusable-homoglyphs-3.3.1.ebuild34
-rw-r--r--dev-python/confusable-homoglyphs/metadata.xml16
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/confusable-homoglyphs/Manifest b/dev-python/confusable-homoglyphs/Manifest
new file mode 100644
index 000000000000..35a3ce6b35c4
--- /dev/null
+++ b/dev-python/confusable-homoglyphs/Manifest
@@ -0,0 +1,5 @@
+DIST confusable_homoglyphs-3.2.0.tar.gz 161937 BLAKE2B ac2c66317b18dd73868b3cbe3b11162550597547da8ee3df5525362b79bd7f61a19bd7446839dfb477d5c2b27464fc88a120c5c6d496de8b86c9e88aabd8aeb0 SHA512 0a46a5bc94393592f6fa088bbe2f95cc301972c55de08231f3607828fcd3c5cb462514b80013283ef8cd8d76eaa3e14258ac8f3433c9c2cd1a89bcebca8fa7f6
+DIST confusable_homoglyphs-3.3.1.tar.gz 325480 BLAKE2B 74a18d442832197cd6371721269ef6389fe2e82e96131656e1ba4d49cb2be9431f715125640c330babe3bce1b2eb34aaf9097a29b6743d2b1c90b5aa53f5dee3 SHA512 c6032479025caa779c79761fc6b34e5b5adab3d784bfe03282b7f5edc7701366ee7897bd4e8a4c264e7a06a59f075ac876bd47fa328accfe981944e70092d40d
+EBUILD confusable-homoglyphs-3.2.0-r2.ebuild 705 BLAKE2B 49ad1605179f09353632496ebc93702b61f026e355937408c651e777319e044c95244640315cc614d330a6b2525cabf07083558aaf3c71d7fa39af46e5c87994 SHA512 91f57ecc8140788fa0c5b1ec4f558179a4b4794d2b08f6b2554a1add21af01aef690379850dcdf45a39ce93f3cd357cb1acf5e2aed733c3f9da21b314c04771b
+EBUILD confusable-homoglyphs-3.3.1.ebuild 710 BLAKE2B 42954cd4efe75a005ebcafb7f1df304696f8e0f5fad0f638ac765118dcb488a1a55eaf49a6a95a9b20cfcc58c6998ebcb215e3ed46363d8256c82233e84652b3 SHA512 7620fc2b11f3b450fbb7df3f53d30f0ad4f0114d0f7db56e01aaf50fe05f00aa7013fe5d1c5be9ea70f3c3f3a9c5501723384e81c3e2d32e3e2f7f73752a6ccb
+MISC metadata.xml 507 BLAKE2B e09380059ead28a19b712bdd2e5095aca97be5b5400020a5229274f5cdf11b33de6a362d1be89023bf9e325db980d264afe242b82b13423ce498a040daccfaf6 SHA512 d4464ead72b9e16cfc760bd5eea9acf09467a4606deba25b3ff87abaf226e3f7078af89e5a306b7c3668bb1572d557ee16565f7bbb14d6cad5b7b3e2cba0c69c
diff --git a/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.2.0-r2.ebuild b/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.2.0-r2.ebuild
new file mode 100644
index 000000000000..3a56823cdf16
--- /dev/null
+++ b/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.2.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Detect confusable usage of unicode homoglyphs, prevent homograph attacks"
+HOMEPAGE="
+ https://github.com/vhf/confusable_homoglyphs/
+ https://pypi.org/project/confusable_homoglyphs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # removed outdated bundled version (for py3.12 compat)
+ rm versioneer.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.3.1.ebuild b/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.3.1.ebuild
new file mode 100644
index 000000000000..cc82b86b0e2e
--- /dev/null
+++ b/dev-python/confusable-homoglyphs/confusable-homoglyphs-3.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Detect confusable usage of unicode homoglyphs, prevent homograph attacks"
+HOMEPAGE="
+ https://git.sr.ht/~valhalla/confusable_homoglyphs/
+ https://pypi.org/project/confusable-homoglyphs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # removed outdated bundled version (for py3.12 compat)
+ rm versioneer.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/confusable-homoglyphs/metadata.xml b/dev-python/confusable-homoglyphs/metadata.xml
new file mode 100644
index 000000000000..4dfb59ace990
--- /dev/null
+++ b/dev-python/confusable-homoglyphs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">confusable-homoglyphs</remote-id>
+ <remote-id type="sourcehut">~valhalla/confusable_homoglyphs</remote-id>
+ </upstream>
+</pkgmetadata>