summaryrefslogtreecommitdiff
path: root/dev-python/configshell-fb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-28 07:37:01 +0100
commit1a39e197a344b8ec7e3ed6c173bdf2a1ccba5b6b (patch)
tree7e7d76b763f13b5096b3bbb3b164edc87dc72b27 /dev-python/configshell-fb
parentdab47ccc26a61cb1fa68f2ab787233a1d12af4d1 (diff)
gentoo auto-resync : 28:06:2023 - 07:37:01
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/Manifest2
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.30.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index b4fa6f2d51d8..dd2cc1e1c299 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1,5 +1,7 @@
DIST configshell-fb-1.1.29-replace-getargspec-1.patch 1398 BLAKE2B 650efe1dad551ad040001cb2f576311806d329bd430874e1dac38a5cb94c4801140f32b628e0089809214466613e8f207ba3aff1a87dd8ca29c05593b551e5d7 SHA512 59c320939d4590dc2933de7d0ad613efd7236868fd898ce1edadbc55d1ecd8667e28a5c03caa80ea12420db3dd0e4de8c36ef5528352920d98acfd881648154a
DIST configshell-fb-1.1.29-replace-getargspec-2.patch 2981 BLAKE2B 88400de96d329c0efd2a9e9cb41f1c53e62c28507439c405874726fccc6093d5fe37e52b6e4b811bf0ccc7616c9a26b83b17e39a257aeab3c4114e1486a32575 SHA512 621b125cde9fcc68f46a3a32fd78190a46f900ec808233a60c4beb22c6109165f0743a341991e6c556dc5a76b7c6a42b703f2a6be91915110f196845a3fa111c
DIST configshell-fb-1.1.29.gh.tar.gz 33192 BLAKE2B 6c9c2146a597572675611afe259122b0ec9614295c4b9b4056d7a16f35004700b1e6fc29e1bf868d9ba6291b781ca35eab77e8adf23c6d23e09de2fb94626f26 SHA512 1b5f573506317119d2420e415abbb856692caa65a7f407f741300eec302d1b442e29d2691f6a192b202b2a5731a7a179d1b03f6cd27780876194d97e4df5f7d0
+DIST configshell-fb-1.1.30.gh.tar.gz 33179 BLAKE2B 8664ec42727fb9bd41600c2844b9b59423c21040e6efc201f40b54abf6d788fa5237d38e2795d0d19706303d99e7ea859b399fd5f122cb04effc643a33b264ac SHA512 b3189130ac047fe28ea987391591b7886f7234864d455a8423d1d65b02a514511e2a32dce1429a6b71cedbc0b7cb6e6e10f29d240b746d222c285f0baa6b46b0
EBUILD configshell-fb-1.1.29-r2.ebuild 1569 BLAKE2B 91663aab642a192425d862f367bc0d307a12063dff5fb4b4a51e2f9dfe9ddf13cfffd73d05a723ce8f0c6d5a6bd54cd473d046830b7540499355835e758c454a SHA512 22b7344090c635bf138e8deb0c8a5c0c00b3b68fd213c0f0eb26674693c14962a321d8fab333af53626e098c43a3b8bf77e45b3fb7a2a651b3f6f4a6ac8fa66a
+EBUILD configshell-fb-1.1.30.ebuild 808 BLAKE2B d8e8db152f2be46ba1371fe22e3cff5bfc6687bf84ded5cdfbbefe44385842e3801d50630507df240edc43b4252bc3dda4a47b4f6a3bb1f96e050d08fc855718 SHA512 8231785847ba0f7c3a93cb7e166453619a0c7afad94efe98e26ee4db2509b16025ecbc944c245626f03c2691bf7682f7b0b426b7d81494ebce2ae6ec35544dcd
MISC metadata.xml 789 BLAKE2B fc1e6e767a4b869c7cfade0a030133a746acdea98b9991740eb82a74f82eb29d495807682a1d521667162ba39a68c966c78ff1e39338d1273d173915e6401a61 SHA512 76a628ddb64f2ce5e0fa09faef29cb7b643e03cee337b9b3554d3a6ac3873be64b8fc66067c93087938e71473f0e2ae3af0a50f0a3b19195b87d69680ded5cd8
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
new file mode 100644
index 000000000000..36b81de5ff30
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.30.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="
+ https://github.com/open-iscsi/configshell-fb/
+ https://pypi.org/project/configshell-fb/
+"
+SRC_URI="
+ https://github.com/open-iscsi/configshell-fb/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
+}