summaryrefslogtreecommitdiff
path: root/dev-python/commentjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/commentjson
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/commentjson')
-rw-r--r--dev-python/commentjson/Manifest2
-rw-r--r--dev-python/commentjson/commentjson-0.9.0-r1.ebuild (renamed from dev-python/commentjson/commentjson-0.9.0.ebuild)17
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/commentjson/Manifest b/dev-python/commentjson/Manifest
index 8116ec53d9b8..c0f2f00e1d9f 100644
--- a/dev-python/commentjson/Manifest
+++ b/dev-python/commentjson/Manifest
@@ -1,3 +1,3 @@
DIST commentjson-0.9.0.gh.tar.gz 15297 BLAKE2B a857b0fa5551079d3d37bff94fb51a903e998c4fb84e0f62a5de28d6eafe0cb8a38b3215515e72c56de0cddb661f109921c801d15b9ba93771290135adaaa5b1 SHA512 cd3d28adecbc445ed3faed7847c65a23829f408cf8aa3fa85544a0f0cf9fa5544b8aff560725cf51921f249123daf9ce9953069e99ca64a312bb4bff652512fe
-EBUILD commentjson-0.9.0.ebuild 781 BLAKE2B 4b3359b12e50dc3e91adc5e946a6497ef267010fd653b1c88a812f6f7a45aacf64dda4c47dcb5dceb16d828c147b1a6e451d5e8465aa69a517b27b74295e5468 SHA512 a95ccfce672f8d9d4f7caa005ebe5840b9dc82f6f9ee881edbc998e831c985fb3569a6507af9d51800b4435d56458cb106575ca7e96b051d31d912a5481e032d
+EBUILD commentjson-0.9.0-r1.ebuild 801 BLAKE2B 30814ef36f082d6ef81f6210a6cab42978ab9190b8e9429f2640e08eac366455b5a8c17850aa2f42d643de2379910461fbcd89f2e5661cf6d94695f2456d1e8a SHA512 f64e4338cf9fd7368d8ce7f105a1cbc434a94abbe14936fdf9d822ec4f7246748f757bdfe4a759674bd89dda12b1a1a78eff991fa580273ef579c8ab724b9314
MISC metadata.xml 351 BLAKE2B c572a2399353ef88fbb0bc49d31eed6607fa157340c3ccc1311a1e2103a5488f66ed09f10d73daf2aa9a062ce36d2635e4bf703a61a9e4e7341b70e8ab1a97a8 SHA512 90aaec57bf7a92233f7761ee780faf9607dfa79d93627fc3c17cbe63aa6d2b41cdc7229fc17e46c2eb155a5749aee379a1a665e3192f44910aee344c89fe6160
diff --git a/dev-python/commentjson/commentjson-0.9.0.ebuild b/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
index d76e173d3810..c90432d94b96 100644
--- a/dev-python/commentjson/commentjson-0.9.0.ebuild
+++ b/dev-python/commentjson/commentjson-0.9.0-r1.ebuild
@@ -4,31 +4,36 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
HOMEPAGE="
https://pypi.org/project/commentjson/
- https://github.com/vaidik/commentjson/"
+ https://github.com/vaidik/commentjson/
+"
SRC_URI="
https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
RDEPEND="
- dev-python/lark-parser[${PYTHON_USEDEP}]"
+ dev-python/lark[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-python/six[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests unittest
src_prepare() {
- # remove unnecessary version bind
- sed -i -e '/lark-parser/s:,<0.8.0::' setup.py || die
+ # remove lark-parser dependency to allow painless upgrade to lark
+ sed -i -e '/lark-parser/d' setup.py || die
distutils-r1_src_prepare
}