summaryrefslogtreecommitdiff
path: root/dev-python/comm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
commit94b475013eb88e152032d5f8c684a7d9ce91e319 (patch)
tree09d40138872fbeea80b96af571a1da4de80bcf73 /dev-python/comm
parent8d3527b916ca7e0a2c8d9b8d064253a2eda02c1f (diff)
gentoo auto-resync : 03:01:2024 - 13:56:25
Diffstat (limited to 'dev-python/comm')
-rw-r--r--dev-python/comm/Manifest2
-rw-r--r--dev-python/comm/comm-0.2.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/comm/Manifest b/dev-python/comm/Manifest
index 386f20f7ba47..3432f1fa011d 100644
--- a/dev-python/comm/Manifest
+++ b/dev-python/comm/Manifest
@@ -1,3 +1,5 @@
DIST comm-0.2.0.gh.tar.gz 8936 BLAKE2B 0ca702f3e4aa2a06f827a4896a3497cd98d1e4bafbf9d92942d8d9c6ee8f81b1300a3f2ae72ba32833574444e4d2a4a1fc20be70638333edcbdc2854ee612708 SHA512 6336d9ff2fcf9016d3616ec5c7f6715e8abffc878a0f5b8dabcd06cd17f851cf562e918bd43b55e435adf6da1e635e7152c3b525a5d718b04e7f98b3c8096505
+DIST comm-0.2.1.gh.tar.gz 9569 BLAKE2B 5af0ba4f82ee69819404cef7e45937d9cfeec0a390c7bf562dce1132a7b916a5d8c80c25f7d78cc44f3fb069959d6c8902aae61ecd4bb07e3036d096e25d35cf SHA512 79f85dcd06a5e849718092a3148f39ad81c36a1903a51bd619f50d044cec6be7ca25e3fe7cd85c9174d76558b52dc77a1c3b49f1ed52b8f83e83a8a6ae7f3f0d
EBUILD comm-0.2.0.ebuild 720 BLAKE2B e23412a690867c990a83168ea611c14f84ecc609b64896547d13ae32cbf90c87fb886e958293c3a3d4754f6275eb048eba126bc04918ba21d64813d71e8ab369 SHA512 193cfa58cbe8dd828242e8ea939881579c685859984dea7c843569ae48e2af1c329cd82a2359ac46b83252a20b5ec682c8d5d145d5dc4b4a4ed4ef696d541025
+EBUILD comm-0.2.1.ebuild 728 BLAKE2B c290e662d72726202b6ea740ebed3d09a1856a4d0c060445849e9821620f3a9d57d57069b6977f7997be58490a178b3973fc16d995c4d7cdbcc6377589136f2c SHA512 1a36619face02deddec7b8501e62663dc0894cdfb4188b57670d0fd7cd783d21819dfecf163553cea78bb365df1b2533f37540fefa289481354f2d38e5c99434
MISC metadata.xml 384 BLAKE2B c122aaf6c2b9e6776b19efa2549030f0267c1d553f92862c5ecf21926f30a9c3cd7564434a573cca6fdbb85485eb49213b4d95100e8de2a29ced9c9c1fa81153 SHA512 b06853ad3cb1775ad70e44c48bca74bcf85c11715291974e7e3ee496344256fc57b91920812f19809e7cf14f6a7f7938531934d6a12740baec0dd984d5d48632
diff --git a/dev-python/comm/comm-0.2.1.ebuild b/dev-python/comm/comm-0.2.1.ebuild
new file mode 100644
index 000000000000..6ddbbf5df8d5
--- /dev/null
+++ b/dev-python/comm/comm-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Python Comm implementation, for usage in ipykernel, xeus-python"
+HOMEPAGE="
+ https://github.com/ipython/comm/
+ https://pypi.org/project/comm/
+"
+# no tests in sdist, as of 0.1.3
+SRC_URI="
+ https://github.com/ipython/comm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/traitlets-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest