summaryrefslogtreecommitdiff
path: root/dev-python/colour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /dev-python/colour
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'dev-python/colour')
-rw-r--r--dev-python/colour/Manifest4
-rw-r--r--dev-python/colour/colour-0.1.5.ebuild25
-rw-r--r--dev-python/colour/files/colour-setup.patch8
-rw-r--r--dev-python/colour/metadata.xml24
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/colour/Manifest b/dev-python/colour/Manifest
new file mode 100644
index 000000000000..5b927a8a5e68
--- /dev/null
+++ b/dev-python/colour/Manifest
@@ -0,0 +1,4 @@
+AUX colour-setup.patch 148 BLAKE2B 41fbf09fa54d8ba88a7b01c240bbb9b26b14f48ecd8d677d5acd16e41d53151f8a443857353be6c593506176e4786caa0001602289add34012e59a463e3c9200 SHA512 2def5f03812b78297fab62f9b7233f32e1923d845f495e1fe3ec18988b30d04b2f6c8908122c87c1738cdec6ac6665c1a41b422fd9a654d08e29ecfa16590eb9
+DIST colour-0.1.5.tar.gz 24776 BLAKE2B 71e2b44c6379f73fa1a70781ae2559e37122e2db982d1f98ab5c4432b4e95a2c60d6489a88025499c36d288f3e9269e65caf9560d7772e2c1c050266c284816f SHA512 09a5160862bf10cd5f4a94e43c63d6f2a5db43bcaae0e9d8f66900113ec04471e22d0bec7412f0289c6f1e6871c1a544f5be36266aa8d6fd5ec274bd461d9df8
+EBUILD colour-0.1.5.ebuild 522 BLAKE2B ecbeb967f660bb134bc1a0b4e3a69facb6a16ff39e3df29b459a0beeebf1eb92d59d4fd940f5cfad270cfb0b694b63614423908cf53fdddea820883469e27482 SHA512 b09f77cabfe1f379ec0f8e055f610b0e072ead2ea68595b5dfc6ba1deb783b187f36092f1aef9bdebf836c21e0990c077c74a82f2301ed3e0225758107e680bc
+MISC metadata.xml 1047 BLAKE2B 5adb3f7fa40a62d63b3ab029a606b58b9745adfdec1f3c9c21686e311b8e84a9125f5ed04d673daf646905af8f1ffa1036441eed872a2c9b602e423574bc8a9f SHA512 8e073dc162f3989ccde634bb8b2531a98f28a8ffe715071858a6b3b03f0d2a30f54c5d10b2e312029981e5ceedc6e9091dd145b57ac432e4774761e8cb3f8234
diff --git a/dev-python/colour/colour-0.1.5.ebuild b/dev-python/colour/colour-0.1.5.ebuild
new file mode 100644
index 000000000000..210b23fa944c
--- /dev/null
+++ b/dev-python/colour/colour-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python color representations manipulation library"
+HOMEPAGE="https://github.com/vaab/colour/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+src_prepare() {
+ rm setup.cfg || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/colour/files/colour-setup.patch b/dev-python/colour/files/colour-setup.patch
new file mode 100644
index 000000000000..833a045fbf82
--- /dev/null
+++ b/dev-python/colour/files/colour-setup.patch
@@ -0,0 +1,8 @@
+--- a/setup.py
++++ b/setup.py
+@@ -60,5 +60,4 @@ if "0.1.5".startswith("%%"):
+
+ setup(
+ extras_require={'test': ['nose', ]},
+- d2to1=True
+ )
diff --git a/dev-python/colour/metadata.xml b/dev-python/colour/metadata.xml
new file mode 100644
index 000000000000..044ffd6b7fa3
--- /dev/null
+++ b/dev-python/colour/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Converts and manipulates common color representation (RGB, HSL, web, ...).
+ Full conversion between RGB, HSL, 6-digit hex, 3-digit hex, human color.
+ One object (Color) or bunch of single purpose function (rgb2hex, hsl2rgb
+ ...). Web format that use the smallest representation between 6-digit (e.g.
+ #fa3b2c), 3-digit (e.g. #fbb), fully spelled color (e.g. white), following
+ W3C color naming for compatible CSS or HTML color specifications. Smooth
+ intuitive color scale generation choosing N color gradients. Can pick
+ colors for you to identify objects of your application.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <remote-id type="github">vaab/colour</remote-id>
+ <remote-id type="pypi">colour</remote-id>
+ </upstream>
+</pkgmetadata>