summaryrefslogtreecommitdiff
path: root/dev-python/colorful
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-python/colorful
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-python/colorful')
-rw-r--r--dev-python/colorful/Manifest3
-rw-r--r--dev-python/colorful/colorful-0.4.1.ebuild23
-rw-r--r--dev-python/colorful/metadata.xml12
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
new file mode 100644
index 000000000000..d01c0fc5e87a
--- /dev/null
+++ b/dev-python/colorful/Manifest
@@ -0,0 +1,3 @@
+DIST colorful-0.4.1.tar.gz 19696 BLAKE2B 9229200853d3050ebe61817fcfd975444a6568cbd490798c8bb2fdf3bb0286f7263d40942bb5edb28f64c6dd28e7a02cab5939d562bd2b091c05232efc3ac37f SHA512 41ce1c35193ebd8fa22bc06afb5536d02cdfc6bde89068693f6ddd1fec140f8823dafab10cf40496f48cb38ad87f874edd6819446b824028575030160b0adc7c
+EBUILD colorful-0.4.1.ebuild 532 BLAKE2B bd550644a69a0682374ac76e328b7aafc8f890e7ebdfd967210ef9d7b96ce37319c02316bd948557459eba64c313aec4da08f0d26bdd1f6b868a339dd4d5b2e5 SHA512 6aad78daba22dae5a680c7747827b4d15d2ede92db8b6cc1ea4d015fa222c5dd114ba45c6c6247699c791f0ba03a2a9790cb8dbc69de6b449a7d8e4378cc53e5
+MISC metadata.xml 390 BLAKE2B 766bad46b3edb503b2b305d7558986f41b07876921006f85a6f2a1fac657052e87d88e2bb3758bd9d622d5bd055e680bad59fe7d4b2860c158e461d06a7adbe3 SHA512 ed2525c21fafc6b9696931da215b190e227456231890ae6559979fe90e58e13501e2cd57dbaf9820b9426cf6136f15127e81c19389799566f419bfdf77870326
diff --git a/dev-python/colorful/colorful-0.4.1.ebuild b/dev-python/colorful/colorful-0.4.1.ebuild
new file mode 100644
index 000000000000..846c46b1efc5
--- /dev/null
+++ b/dev-python/colorful/colorful-0.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right in Python"
+HOMEPAGE="https://github.com/timofurrer/colorful"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/colorful/metadata.xml b/dev-python/colorful/metadata.xml
new file mode 100644
index 000000000000..cc035fa6a23a
--- /dev/null
+++ b/dev-python/colorful/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">colorful</remote-id>
+ <remote-id type="github">timofurrer/colorful</remote-id>
+ </upstream>
+</pkgmetadata>