summaryrefslogtreecommitdiff
path: root/dev-python/colorful/colorful-0.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
commit1fbaf1314579f2155166bebd1ddfe6131d400807 (patch)
treeb034ac67fab73c50b138ed5a57e5823cda058299 /dev-python/colorful/colorful-0.5.6.ebuild
parentf50726afc610727258a31ddfa8b3b32639b20a10 (diff)
gentoo auto-resync : 08:01:2024 - 06:56:53
Diffstat (limited to 'dev-python/colorful/colorful-0.5.6.ebuild')
-rw-r--r--dev-python/colorful/colorful-0.5.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/colorful/colorful-0.5.6.ebuild b/dev-python/colorful/colorful-0.5.6.ebuild
new file mode 100644
index 000000000000..55d9fa2e9996
--- /dev/null
+++ b/dev-python/colorful/colorful-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right, in Python"
+HOMEPAGE="
+ https://pypi.org/project/colorful/
+ https://github.com/timofurrer/colorful/
+"
+SRC_URI="
+ https://github.com/timofurrer/colorful/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}