summaryrefslogtreecommitdiff
path: root/dev-python/coloredlogs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/coloredlogs
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/Manifest3
-rw-r--r--dev-python/coloredlogs/coloredlogs-14.0.ebuild46
-rw-r--r--dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch35
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
index d8c17974828f..33ca905a534f 100644
--- a/dev-python/coloredlogs/Manifest
+++ b/dev-python/coloredlogs/Manifest
@@ -1,4 +1,7 @@
AUX coloredlogs-10.0-skip-sandbox-violation-tests.patch 5312 BLAKE2B bb7ac55706ca89a16d7727d796e586a665730d25f1cb69aa833b24082e42f0f5aed3a5d4f627e2015bb189ea3422ab1bcc2982933a7a123990adf821a7a2fdc2 SHA512 071ac2255ce9e6e4e379065ce377e86c3ebc9e910951d647cd19e15431983cb966eba7e1bb2a2431ecb91aa09f3802a5e365683a2e545e0e5fb2d58432748bfc
+AUX coloredlogs-14.0-fix-install-prefix.patch 1474 BLAKE2B fbd2751c0a4f0f7a412428839b5bd8891b863f609d0c890887b85737d7cce9480ccbd2c4c6bb4e6e600b5ef850c065862ce7867b352f41e262022e21841cf1a1 SHA512 50063a6c14d1d4baf76d6409fc9776ec366500f7fa9b1b9e1270dac456b174b015b907f067c5641d4e74b75abc62ca4cdc641e55af88216101ddc4916198f1c5
DIST coloredlogs-10.0.tar.gz 273273 BLAKE2B 775b12718d780da396d74c7f960cdbbd4858c793bf3eefb53d29e9f6b415f682110ae2c7ac631be230578946a2fab8d75e0c3aa487ccd952bb05443f0a85700c SHA512 f4a51fd8fa92ea4e2ef0b58305dcc4bbe12851e722fc85cfd4f48a9388002efced52bcf027f6dc4c525b095f3f953970e73928fdce3245ab4f9d13ae36b9d498
+DIST coloredlogs-14.0.tar.gz 275863 BLAKE2B 0a8c026220955397378ad2b43a69c89c5710a09e2d9ed81a3f25408c60e171f4b8f78239696a0bc1b51fc3dd9bfca80df63e1f1d7afb6bee0046209a089e0d6d SHA512 3434a95f3216d19af5d7a48324e5afd5e975f92d9f6b99f40df2c0a635f1738e0bc6d7277a549a42a0fec5a8601f82908c4b0205ceeb3666f49210f66fe58671
EBUILD coloredlogs-10.0.ebuild 973 BLAKE2B 4b4a9a736ee0a943b153b62e5b83c380f16c251bdb00be5bcb546a044c22f4d0c2978bda0b7835095daadcb389f189da0ebe074fe787e99bca319082690d67a2 SHA512 781543a8f486c50554f1270d18ff5c393396dcbd94608c17a75ee8d2ba0aafc95b539df42ffcd1bbe018030996699495e5820da8dc48b41afb3009d5fa7f04c8
+EBUILD coloredlogs-14.0.ebuild 1209 BLAKE2B c320068753a8d5e7f7a1541f990a83ffde29a0469788f18fc10326f444a198595dadd34a11cff68408718071d82df2bcce2bfeaa4d1921105117f85cd61e2c22 SHA512 f77a452c0fcf8437721c4abd4279e329450ddeec312beff16fe0503d7ec405446e45114bec79eb5aff109670015cc8a00ec82f8aebf500b18d73bc9e0b3f8ab3
MISC metadata.xml 390 BLAKE2B 6f1ce9de711c22d533fd07fb56b62c6f30c78aea141f78b4946fd9400b6daaff70eec5334aad41b92ffc28829d9edb3f6ef1e2515ab5a18c7e139265043f8a98 SHA512 4df2d5312905b2be06239d81f2274ae4e6517f48d62ec54d5d755bb08cccaaece3531b391f45097590f039db10b8bcf6ff265a28506a0f8096f121fda85e498c
diff --git a/dev-python/coloredlogs/coloredlogs-14.0.ebuild b/dev-python/coloredlogs/coloredlogs-14.0.ebuild
new file mode 100644
index 000000000000..89c3d911e9f4
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-14.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install-prefix.patch" )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # test_cli_conversion requires the package to be installed
+ distutils_install_for_testing
+ # test_auto_install fails because the pth file isn't being loaded
+ pytest -vv ${PN}/tests.py \
+ --deselect ${PN}/tests.py::ColoredLogsTestCase::test_auto_install \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
new file mode 100644
index 000000000000..d6b60c3bdf57
--- /dev/null
+++ b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
@@ -0,0 +1,35 @@
+commit 6f566c799323feb3b8dc2b82e62953040a6a5129
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sat Sep 26 10:30:37 2020 +0200
+
+ setup.py: use absolute paths for pth files
+
+ On some systems (such as PyPy3 on Gentoo), distutils' `data` path is not
+ `sys.prefix`, which means that we cannot rely on relative paths.
+
+diff --git a/setup.py b/setup.py
+index 057dd80..7674adc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -66,9 +66,9 @@ def find_pth_directory():
+ Determine the correct directory pathname for installing ``*.pth`` files.
+
+ To install a ``*.pth`` file using a source distribution archive (created
+- when ``python setup.py sdist`` is called) the relative directory pathname
+- ``lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
+- option to ``setup()``.
++ when ``python setup.py sdist`` is called) the directory pathname
++ ``/usr/lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
++ option of ``setup()``.
+
+ Unfortunately this breaks universal wheel archives (created when ``python
+ setup.py bdist_wheel --universal`` is called) because a specific Python
+@@ -81,7 +81,7 @@ def find_pth_directory():
+ directory without hard coding its location.
+ """
+ return ('/' if 'bdist_wheel' in sys.argv
+- else os.path.relpath(distutils.sysconfig.get_python_lib(), sys.prefix))
++ else distutils.sysconfig.get_python_lib())
+
+
+ setup(name='coloredlogs',