summaryrefslogtreecommitdiff
path: root/dev-python/coloredlogs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 15:24:16 +0000
commit867ef65cd897014478ed65034b1ac3f139289a77 (patch)
tree3af9d9e893bca02bb644786f42dfaf2678d6908d /dev-python/coloredlogs
parentf077c725ef746943ec7902350b30ff569f5995ba (diff)
gentoo auto-resync : 08:11:2022 - 15:24:16
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/Manifest1
-rw-r--r--dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
index c93b382bbe07..31ebacde6b3b 100644
--- a/dev-python/coloredlogs/Manifest
+++ b/dev-python/coloredlogs/Manifest
@@ -1,4 +1,5 @@
AUX coloredlogs-14.0-fix-install-prefix.patch 1474 BLAKE2B fbd2751c0a4f0f7a412428839b5bd8891b863f609d0c890887b85737d7cce9480ccbd2c4c6bb4e6e600b5ef850c065862ce7867b352f41e262022e21841cf1a1 SHA512 50063a6c14d1d4baf76d6409fc9776ec366500f7fa9b1b9e1270dac456b174b015b907f067c5641d4e74b75abc62ca4cdc641e55af88216101ddc4916198f1c5
DIST coloredlogs-15.0.1.tar.gz 278520 BLAKE2B 446aea9adfc8a1ea7f2e5b4a0279d124a3e174feec4a6d9346059fa00fbcb2717d6480392051cc44f0c1f66e022cfc03238acae59b9496e9f70695d99143dfd6 SHA512 577af26af8d27bca3f10e6aaa257245aba608cc3832985ba57bcb2b590b10bf054796a2210749c15ee1b1a17623e007e4ac3ba17bed6af95544f85f5dfafaf21
+EBUILD coloredlogs-15.0.1-r1.ebuild 1113 BLAKE2B db11a52e534e4a907a0cf493db330a2457ffe2fffd01603516db14084eb56420665d95f3b9bb006f42c9579007787c0bb401e8322c89fcdbbc014493dd8e71dc SHA512 6bab121c269e364f663000d9f66fda759d507a18640804e8a9af65ce0a110d83bf3f5eb4cfe63db17acd998f062e17e98d866c75b1e7414e55be20967b676133
EBUILD coloredlogs-15.0.1.ebuild 1164 BLAKE2B 0597a18a441241b9f8fef0958fa99e447103df74f5cc01b603710d35a5b9adc11916e61d476215ae54e9ed7ff20cd4aee0aeb71581058787853fa99c6a758bda SHA512 7980fc0120b203387e250c7e2bf4a41413d18cd11800f2e383a2e663f8a6aa7fe300694867148df6d794c8a3f302b71a9da4817df212d8ea6dc7eab0ef2a9871
MISC metadata.xml 391 BLAKE2B 23995da8632cec6cc75466238f135357b63b28a1d1701f89ff0b565a9e2f7b2a2a78514627de45d2704b02e2f82f11e4b6894f4a6090c9c3d482de5b4036b577 SHA512 b52d94fabe4466b02a4e81dc773786000a8ca6189a7b928e52beb0dd291186cf4331d0ed4b139f0017e18b6ec48238fcf5104dccc5b4abe3aa7e70e60cc5830a
diff --git a/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild b/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild
new file mode 100644
index 000000000000..6512b8283079
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-15.0.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/humanfriendly-9.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/coloredlogs-14.0-fix-install-prefix.patch" )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test_auto_install fails because the pth file isn't being loaded
+ coloredlogs/tests.py::ColoredLogsTestCase::test_auto_install
+)
+
+python_test() {
+ epytest coloredlogs/tests.py
+}