summaryrefslogtreecommitdiff
path: root/dev-python/coloredlogs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/coloredlogs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/coloredlogs')
-rw-r--r--dev-python/coloredlogs/Manifest4
-rw-r--r--dev-python/coloredlogs/coloredlogs-6.1.ebuild46
-rw-r--r--dev-python/coloredlogs/files/coloredlogs-2.0-skip-cli-test.patch20
-rw-r--r--dev-python/coloredlogs/metadata.xml12
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
new file mode 100644
index 000000000000..9195ed6259ec
--- /dev/null
+++ b/dev-python/coloredlogs/Manifest
@@ -0,0 +1,4 @@
+AUX coloredlogs-2.0-skip-cli-test.patch 842 BLAKE2B b6e17539f22349bcd20ba4ec64f03dd2e8e291e7f8e892765cc675d88b338d64f5df12b28b1909d0554eb42bfc70cc564f603d026f05e2ca4fe0952b6021af91 SHA512 98e5e8d207de67abf22d0de5729cf6926802329e1a32977dc95155490cf32c6b94b69f8e78a410a718bae073e4d6d618c515dcd7318b057671bb91fcf84c4424
+DIST coloredlogs-6.1.tar.gz 28057 BLAKE2B bbb5946db3e6cbfae0b9947d2aa29769858833e35213a44a5be4ceb434021ee8c583ff00c980b9ab4fc533f6fec80e151895097b6a87c44257ef0fd5c7ab0bab SHA512 834cf993e7ffd3328644d334912fcf5a5156a441c6184643b38e5f356d46d7b5c48e02ee1e1b432265052c7a5ab1071ba456e575217a4a762f8387131059c405
+EBUILD coloredlogs-6.1.ebuild 1206 BLAKE2B b1a7e533a4fab3a0cabccded7b2452a9986e70c67aba9b13d864d5c247193122f6febc532f69afbe5dde82c7c56715d167a74be3a328e30a6c4a3e5da2de993c SHA512 65ca3a1698c4583dc3ed47774984a1d272efa4f4f476d4fd5139599b1560a1cdab34f7b1bff8c66e2022965b056a40ebd7a5ee7c979c14218a7336cf7f182c78
+MISC metadata.xml 390 BLAKE2B 6f1ce9de711c22d533fd07fb56b62c6f30c78aea141f78b4946fd9400b6daaff70eec5334aad41b92ffc28829d9edb3f6ef1e2515ab5a18c7e139265043f8a98 SHA512 4df2d5312905b2be06239d81f2274ae4e6517f48d62ec54d5d755bb08cccaaece3531b391f45097590f039db10b8bcf6ff265a28506a0f8096f121fda85e498c
diff --git a/dev-python/coloredlogs/coloredlogs-6.1.ebuild b/dev-python/coloredlogs/coloredlogs-6.1.ebuild
new file mode 100644
index 000000000000..12bcf1711a21
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/humanfriendly-2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/capturer-2.2[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/verboselogs-1.5[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-skip-cli-test.patch )
+
+python_test() {
+ # Sandbox violations
+ sed \
+ -e 's:test_system_logging:_&:g' \
+ -e 's:test_syslog_shortcut_simple:_&:g' \
+ -e 's:test_syslog_shortcut_enhanced:_&:g' \
+ -i ${PN}/tests.py || die
+ esetup.py test
+}
diff --git a/dev-python/coloredlogs/files/coloredlogs-2.0-skip-cli-test.patch b/dev-python/coloredlogs/files/coloredlogs-2.0-skip-cli-test.patch
new file mode 100644
index 000000000000..cacd016159e9
--- /dev/null
+++ b/dev-python/coloredlogs/files/coloredlogs-2.0-skip-cli-test.patch
@@ -0,0 +1,20 @@
+ coloredlogs/tests.py | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/coloredlogs/tests.py b/coloredlogs/tests.py
+index 2010b12..7ab18a8 100644
+--- a/coloredlogs/tests.py
++++ b/coloredlogs/tests.py
+@@ -160,12 +160,6 @@ class ColoredLogsTestCase(unittest.TestCase):
+ for name in 'debug', 'info', 'warning', 'error', 'critical':
+ assert name.upper() in output
+
+- def test_cli_conversion(self):
+- """Test the command line HTML conversion."""
+- output = main('coloredlogs', '--convert', 'coloredlogs', '--demo', capture=True)
+- # Make sure the output is encoded as HTML.
+- assert '<span' in output
+-
+ def test_implicit_usage_message(self):
+ """Test that the usage message is shown when no actions are given."""
+ assert 'Usage:' in main('coloredlogs', capture=True)
diff --git a/dev-python/coloredlogs/metadata.xml b/dev-python/coloredlogs/metadata.xml
new file mode 100644
index 000000000000..42593b5baca9
--- /dev/null
+++ b/dev-python/coloredlogs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">coloredlogs</remote-id>
+ <remote-id type="github">xolox/python-coloredlogs</remote-id>
+ </upstream>
+</pkgmetadata>