summaryrefslogtreecommitdiff
path: root/dev-python/colorama
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-25 15:53:58 +0100
commitb8c48743664466ac0f638f0949fd78bfb9f5eae6 (patch)
treedd60615a286df950811f8267c0631e1fd97eac58 /dev-python/colorama
parentcf9065b9fe1f8c33a6e488fce1ee75d893cd351f (diff)
gentoo auto-resync : 25:10:2022 - 15:53:58
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/Manifest2
-rw-r--r--dev-python/colorama/colorama-0.4.6.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index f0bb20f2a6d5..14bed51e2a5c 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -1,3 +1,5 @@
DIST colorama-0.4.5.gh.tar.gz 113373 BLAKE2B d7b071b1efa585c26c48f26af7a0df9bff25e3986f2615889fd25c34d785c256ac3c4655375f13e7d1bc6972f7fa64bd48a819d988160ceb75fda356d645876d SHA512 d4d3b2a4c6a0966b5c15a12cd789e4b68e5b632c4d745d93fcff5e250fe10e5d45dd2a8bd25f4399cca31a358aecf99f354aa3e1b74369ae382b51bd6c87644f
+DIST colorama-0.4.6.gh.tar.gz 116300 BLAKE2B 5b8f013a0cfa227dc750456d28af83dd6322000a3982e680d0cf051f6ae964b630f2889a0f1b78fe1cab465b25a52db07516cee9cbd99575dae38a86c5b69bd0 SHA512 2b269b190041398a1808b0b5147e47422b4451a1bc91841d0957572214ba8addd731c8932afdc60bfbba9833a0fe6c9c5c2ecb150613f13498f661799d625e4f
EBUILD colorama-0.4.5.ebuild 1150 BLAKE2B 104fb49ae64ebb9224d0e66492c3351a08cbb5e5538defd75e0ae9afc998512a97f781c0e83b59f0c564d13b51f361c19d7cead18832b92251b643ca522b066f SHA512 749e7ddbaf1fc67c4b5c7cdccdc411789811afdc6d10c2b46806d0cccdb4d9ea018b3858bc354cd72d19db077cdc76174876dab68339d2feab1f21e772b9a512
+EBUILD colorama-0.4.6.ebuild 1157 BLAKE2B d0938b8e91910b78d5b9446833f0367b0c7d05c5427e01f75ac2e2302f0e7aa9552199b67b2c540f5e96e5f6470e9d7c5eeeff02b31369554d692ace7b9bc1f2 SHA512 4c66adab78df857a3b23bfac44d169dd1e97a5f37fa08cc4a602aefe924247257538d894b0f071210078adae532ef9b0d51aba4a06fa3a09ba6e217afa9960b1
MISC metadata.xml 526 BLAKE2B f8f74b3797df9f8b0ab5ea81b6318d099a041cc3aac741084802272fdc7aaffdabc1269025f5e2b819cfe4608391a0857d208c487cc8f018578610faaad9f401 SHA512 dee4a202781edd36049ee9738dc9e90ffa63aa3874b389b5d0285147fbf86a577c15d55a868c0714ef982f78a2054636f464d6609af0693639d2449ae3d2ea53
diff --git a/dev-python/colorama/colorama-0.4.6.ebuild b/dev-python/colorama/colorama-0.4.6.ebuild
new file mode 100644
index 000000000000..08425bfd8fbf
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama/
+"
+SRC_URI="
+ https://github.com/tartley/colorama/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "${EPYTHON} -m pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}