summaryrefslogtreecommitdiff
path: root/dev-python/colorama
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/colorama
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/Manifest5
-rw-r--r--dev-python/colorama/colorama-0.3.3.ebuild24
-rw-r--r--dev-python/colorama/colorama-0.3.9.ebuild29
-rw-r--r--dev-python/colorama/metadata.xml20
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
new file mode 100644
index 000000000000..1f9daf0c5ae1
--- /dev/null
+++ b/dev-python/colorama/Manifest
@@ -0,0 +1,5 @@
+DIST colorama-0.3.3.tar.gz 22765 BLAKE2B 3dc399c3a073fba825e85c667c6af1a5b8777dc65ff5ae8fcdb7fe6d20a3193ff391a28140ee90316893250a61b77bd8efca9df03ae88c7f20c24545c8f30e4c SHA512 8e6177ea60ab8f1267ce982f23803a9d2eb0c4550d7eac4776416d62a99d1ce03254fc64cc959ca95e2409ceeff081d4d19359c383e969dfb921b44c56914495
+DIST colorama-0.3.9.tar.gz 25053 BLAKE2B f633a188d032c41d0b6de60540ca1774dd8f3e8fe2e558333baf09855db30fa7a7ade5944ff12e4ca1a3685930d10a02009162733666d711ad25a16ee96ace55 SHA512 248e3d3d1f95cb85baf55ef4d705508213b81edfb04b39fe9a7bc9c7ac564986726ab6e9d9f73d64ee02e1c9b86d4c6bba40543590dbd170180a37d69e07b627
+EBUILD colorama-0.3.3.ebuild 677 BLAKE2B 38f450c166eb9f0376274e8de22d6d9a821b9219c5a6b045ba5f8624089366d89b10dd8cd647b299efda1e815cffe444a9e64b0f85967be861591a426b6ccee4 SHA512 0a08f8a7c55b8b5d06fa876c00c2d6882d7af14ad9406e2f8a05871c96bffcc6c15e7db1f1b6a8ab6ef0dc093d93887c4036d6400db8bc4d1cc466fda9e6be44
+EBUILD colorama-0.3.9.ebuild 775 BLAKE2B 03e3db3897548de6c5a73822134d8eac63e03de4c98dd7b7bd2cce5ed0f1ba3c30c9ab78e9eee34da992308752bd8f104bfd5470248e3e1d2e323e4cc4e1d15f SHA512 9ffd1bd0c39a9ca250a6ffd9da05325dc37cf600ac819ca63eac5ec4b5eaa1b17c005854aded788e2323810f245c878defd1ce296fd76bed0f38f332653e408e
+MISC metadata.xml 682 BLAKE2B 9e9eccb56152824c5d47896af7ae8a699a9a614437f20008fbf9c793e0b79cf3dfb0fb6b9da6d36be4d699b2df8817f74a74e098b8fa945e08734d9f068cca12 SHA512 0a9144ad52b490c2e607eae85aced164f4c2f15c152592ca67a588d659c34c3baa16105746fd4a6894c49ca31ee4b0e1b18957cb7c421fc788cbc933afb3e895
diff --git a/dev-python/colorama/colorama-0.3.3.ebuild b/dev-python/colorama/colorama-0.3.3.ebuild
new file mode 100644
index 000000000000..344ddc5ebdc8
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/colorama/colorama-0.3.9.ebuild b/dev-python/colorama/colorama-0.3.9.ebuild
new file mode 100644
index 000000000000..7a1cb051c8b4
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/colorama/metadata.xml b/dev-python/colorama/metadata.xml
new file mode 100644
index 000000000000..993d1023b88b
--- /dev/null
+++ b/dev-python/colorama/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Makes ANSI escape character sequences, for producing colored terminal text
+ and cursor positioning, works under MS Windows.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">colorama</remote-id>
+ <remote-id type="github">tartley/colorama</remote-id>
+ </upstream>
+</pkgmetadata>