summaryrefslogtreecommitdiff
path: root/dev-python/colander
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/colander
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/colander')
-rw-r--r--dev-python/colander/Manifest3
-rw-r--r--dev-python/colander/colander-1.3.1.ebuild56
-rw-r--r--dev-python/colander/metadata.xml11
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/colander/Manifest b/dev-python/colander/Manifest
new file mode 100644
index 000000000000..3cbe5d0d46da
--- /dev/null
+++ b/dev-python/colander/Manifest
@@ -0,0 +1,3 @@
+DIST colander-1.3.1.tar.gz 119999 BLAKE2B 8677dc49eb24b353dc42e858da4e745e711cf852226079190e475f45e6dec341d429cf3d62cfa6b4835b9bd137956ef6a04eb7f1684807bd5f230e114f3ee2e5 SHA512 0aa9063e6f88ef63b5378cd93d3b121c8323e4632dcff31f143d2ee6dd33edb93a7fedfa06ca250288f7bc194a534f1027b89c9c6cc92765cf4348709e539da5
+EBUILD colander-1.3.1.ebuild 1531 BLAKE2B 8857f52c6c53d2fb7c1254f311a1723b346342e2e9beac3bff63ea2c179200ac5a3a86a03da69b1989dbd0e9ef6d9a445c8e2ded0840d6d8906ae23eb91af60e SHA512 7fcf9eefa01a40d928d8bf97c326692be3d66498a03aacfa51f13e2bd74c00bb645896fac774b000bcdf71f4fca19665c533b914267ca093ec108022b4206201
+MISC metadata.xml 311 BLAKE2B 369a77b1ef148e7c46c7f3eebc89ec61b45295ae10c9882bff3ed33178ef80e671cba4327d31f0a1c7a3ffbc65c52c8e546f9e663b7291636d6b764e88347324 SHA512 c0fe889c10d25c88c37e781c6e355c51f1c2c24615d616170da287c6bce490f6cd6b501a783c5a4e98f7c00c945fb686e066422271d5f43495c5c68e459c7f7f
diff --git a/dev-python/colander/colander-1.3.1.ebuild b/dev-python/colander/colander-1.3.1.ebuild
new file mode 100644
index 000000000000..b646c5102f01
--- /dev/null
+++ b/dev-python/colander/colander-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple schema-based serialization and deserialization library"
+HOMEPAGE="https://docs.pylonsproject.org/projects/colander/en/latest/ https://pypi.org/project/colander/"
+MY_P=${P/_beta1/b1}
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+# MIT license is used by included (modified) iso8601.py code.
+LICENSE="repoze MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+# Depend on an ebuild of translationstring with Python 3 support.
+RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}] )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.rst COPYRIGHT.txt README.rst )
+
+python_prepare_all() {
+ # Remove pylons theme since it's not included in source
+ sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # https://github.com/Pylons/colander/issues/38
+ emake -C docs html SPHINXOPTS=""
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/colander/metadata.xml b/dev-python/colander/metadata.xml
new file mode 100644
index 000000000000..bef772ba1b90
--- /dev/null
+++ b/dev-python/colander/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">colander</remote-id>
+ </upstream>
+</pkgmetadata>