summaryrefslogtreecommitdiff
path: root/dev-python/cmd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/cmd2
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest2
-rw-r--r--dev-python/cmd2/cmd2-2.3.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index b4fdc26a8106..45fc173c88d2 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,3 +1,5 @@
DIST cmd2-2.2.0.tar.gz 667076 BLAKE2B babdf4034ea45cebce0a9b037e0bef0127c924e358c68ab6a2b95e73ed3be4577dead28d2eebce721432fefe7d2590a3e904ba84dc17bf7c06e3f777dc7b0db0 SHA512 20c204c5e5996e18face62066a179a9833c468724a947042a3b5aaf49940cad0c773ea22e7f40b8c721f7362dcefa9eb72072710072e608c4adab615332bdc22
+DIST cmd2-2.3.0.tar.gz 673314 BLAKE2B a4ec117af937157d9d4c74d73652bb89998289b9f6ae1548cf064a7f5d964aa77576b00f5c530886f04a2f39f3969a26da4a5752a654b6cbb8b2cbde40907831 SHA512 615b88abd64e0909fc9d24a495060d2d45cf962b2293b91e3bb4e24fa0f90e8e6c07fe5c29a2e0915392fac365960cca418aa4e27b50718c45e9d91397802f30
EBUILD cmd2-2.2.0.ebuild 1396 BLAKE2B 2a14076f2fb23f65fa8a50330df0c89c90aa33a9feb989f2782c6ec24a56556f28f7233ef0b682cdc9e4a3de1bb3d77fce380598d7cc1af9036aeea272457747 SHA512 e2c80c7bf92acff359ab6399154553d49de4314e5eb6714ec34dd7cb2657bc1c2902d0ac4dab269a9f5d087e0498ae2d51618fa8e4963c307b9c0ab3cd76f4c4
+EBUILD cmd2-2.3.0.ebuild 1401 BLAKE2B 3c79e282225eb4c9624d802f3833194243f3dedcd49b1678ce707112e0d283e105b93ecc49b025d7713a7a7eddb12f404c23d58475977f2f063035ae913bb73f SHA512 809faecf21532bfee68d55a8f25079a41cd931d5992f43fd944f5dff8090d77555154052473b7add563876b07ad029bd57a3ef828ad8d9a3c31ee86debf8dbbb
MISC metadata.xml 522 BLAKE2B 39d319b6a64a7b54568a3fbd3d7db9adf7719b690a8f086018ce41f0595db157b1f7825ce28afb4fb0d748ca0d6dc21d79e480361b69b4bf29c0efc2d2540bba SHA512 57315c23dd64534085502e59f0b8ca01ef8088d5a2b16ed807631a1f36a523768960754b00619e802333552c405e2984e314d91003f7a624da6f1eb8e8e4b98a
diff --git a/dev-python/cmd2/cmd2-2.3.0.ebuild b/dev-python/cmd2/cmd2-2.3.0.ebuild
new file mode 100644
index 000000000000..c892c9da8cf5
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel) + which(1).
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ sys-apps/which
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}